BU SERVİS, GOOGLE TARAFINDAN SAĞLANAN ÇEVİRİLER İÇEREBİLİR. GOOGLE, HERHANGİ BİR GARANTİ, GÜVENİLİRLİK VE TİCARİ ELVERİŞLİLİK, BELİRLİ BİR AMACA UYGUNLUK VE İHLAL ETMEME GARANTİLERİ DAHİL OLMAK ÜZERE AÇIK VEYA ZIMNİ GARANTİLER DE DAHİL OLMAK ÜZERE, AÇIK VEYA ZIMNİ TÜM GARANTİLERİ REDDEDER.

Kaspersky Lab web sitesi, Google Çeviri tarafından desteklenen çeviri yazılımı kullanılarak size kolaylık sağlamak amacıyla tercüme edilmiştir. Doğru bir çeviri sağlamak için makul çabalar sarf edilmiştir, ancak otomatik çeviri mükemmel değildir ve insan çevirmenlerinin yerini alması amaçlanmamıştır. Çeviriler, Kaspersky Lab web sitesinin kullanıcılarına bir hizmet olarak sunulur ve "olduğu gibi" sağlanır. İngilizce'den başka bir dile çevrilmiş herhangi bir çevirinin doğruluğu, güvenilirliği veya doğruluğu konusunda açık ya da zımni hiçbir garanti verilmemektedir. Çeviri yazılımı sınırlamaları nedeniyle bazı içerikler (görüntüler, videolar, Flash vb. Gibi) doğru bir şekilde çevrilemeyebilir.

KLA10910
PostgreSQL'de birden fazla güvenlik açığı
Yüklendi : 07/05/2018
Bulunma tarihi
?
12/09/2016
Şiddet
?
Yüksek
Açıklama

PostgreSQL'de 9.1.23'ten önce 9.2.18'den önce 9.2.x, 9.3.14'ten önce 9.3.x, 9.4.9'dan 9.4.x öncesi ve 9.5.4'ten önceki 9.5.x'de birden fazla ciddi güvenlik açığı bulunmuştur. Kötü niyetli kullanıcılar bu güvenlik açıklarından yararlanarak hizmet reddine, hassas bilgilere ulaşmalarına, olasılıkla isteğe bağlı kod çalıştırmalarına ya da öncelikleri kazanmalarına neden olabilir.

Aşağıda güvenlik açıklarının tam listesi:

  1. Bilinmeyen bir güvenlik açığı, hizmet reddine neden olmak için özel hazırlanmış bir SQL deyimiyle uzaktan kullanılabilir;
  2. Bilinmeyen bir güvenlik açığı, hassas bilgiler edinmek veya olasılıkla isteğe bağlı kod çalıştırmak için özel hazırlanmış bir SQL ifadesi aracılığıyla uzaktan kullanılabilir;
  3. Bilinmeyen bir güvenlik açığı, CREATEDB ve CREATEROLE rolleriyle kimliği doğrulanmış kullanıcılar tarafından, veritabanı veya rol adlarındaki özel karakterleri kullanarak süper kullanıcı avantajları elde etmek için uzaktan kullanılabilir.

Teknik detaylar

Güvenlik açığı için hizmet reddi (1), NULL işaretçi hatası ve sunucu çökmesinden sonra oluşur.

Güvenlik açığı (2) için özel olarak hazırlanmış SQL deyimleri her zaman CASE / WHEN komutlarını veya bir CASE ifadesi için kullanılan farklı türlerde değerler gerektiren eşitlik operatörünü uygulayan satır içi SQL işlevini içerir.

Güvenlik açığı (3) için özel karakterler çift tırnak, backsplash, satır başıdır.

Etkilenmiş ürünler

PostgreSQL 9.1.23'ten önce
9.2.18 öncesi PostgreSQL 9.2.x
PostgreSQL 9.3.x önce 9.3.14
9.4.9'dan önceki PostgreSQL 9.4.x
PostgreSQL 9.5.x önce 9.5.4

Çözüm

En son sürüme güncelle
PostgreSQL'i edinin

Etkiler
?
CI 
[?]

OSI 
[?]

PE 
[?]

DoS 
[?]
Alakalı ürünler
PostgreSQL
CVE-IDS
?

CVE-2016-5424
CVE-2016-5423


Orijinaline link