DIESER SERVICE KANN ÜBERSETZUNGEN VON GOOGLE ENTHALTEN. GOOGLE ÜBERNIMMT KEINERLEI VERANTWORTUNG FÜR DIE ÜBERSETZUNGEN. DARUNTER FÄLLT JEGLICHE VERANTWORTUNG IN BEZUG AUF RICHTIGKEIT UND ZUVERLÄSSIGKEIT SOWIE JEGLICHE STILLSCHWEIGENDEN GEWÄHRLEISTUNGEN DER MARKTGÄNGIGKEIT, NICHT-VERLETZUNG VON RECHTEN DRITTER ODER DER EIGNUNG FÜR EINEN BESTIMMTEN ZWECK.

Die Website von Kaspersky Lab wurde für Ihre Bequemlichkeit mithilfe einer Übersetzungssoftware von Google Translate übersetzt. Es wurden angemessene Bemühungen für die Bereitstellung einer akkuraten Übersetzung unternommen. Bitte beachten Sie, dass automatisierte Übersetzungen nicht perfekt sind und menschliche Übersetzer in keinem Fall ersetzen sollen. Übersetzungen werden den Nutzern der Kaspersky-Lab-Website als Service und "wie sie sind" zur Verfügung gestellt. Die Richtigkeit, Zuverlässigkeit oder Korrektheit jeglicher Übersetzungen aus dem Englischen in eine andere Sprache wird weder ausdrücklich noch stillschweigend garantiert. Einige Inhalte (z. B. Bilder, Videos, Flash, usw.) können aufgrund der Einschränkungen der Übersetzungssoftware möglicherweise nicht inhaltsgetreu übersetzt werden.

KLA10910
Multiple vulnerabilities in PostgreSQL
Aktualisiert: 03/29/2019
Erkennungsdatum
?
12/09/2016
Schweregrad
?
Hoch
Beschreibung

Multiple serious vulnerabilities have been found in PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, 9.4.x before 9.4.9, and 9.5.x before 9.5.4. Malicious users can exploit these vulnerabilities to cause denial of service, obtain sensitive information, possibly execute arbitrary code or gain priveleges.

Below is a complete list of vulnerabilities:

  1. An unknown vulnerability can be exploited remotely via a specially crafted SQL statement to cause denial of service;
  2. An unknown vulnerability can be exploited remotely via a specially crafted SQL statement to obtain sensitive information or possibly execute arbitrary code;
  3. An unknown vulnerability can be exploited remotely by authenticated users with CREATEDB and CREATEROLE roles to gain superuser priveleges by using special characters in database or role names.

Technical details

Denial of service for vulnerability (1) occurs after NULL pointer dereference and server crash.

Specially crafted SQL statements for vulnerability (2) always contain CASE/WHEN commands or inline SQL function, which implements the equality operator requiring values of different types, used for a CASE expression.

Special characters for vulnerability (3) are double quote, backsplash, carriage return.

Beeinträchtigte Produkte

PostgreSQL before 9.1.23
PostgreSQL 9.2.x before 9.2.18
PostgreSQL 9.3.x before 9.3.14
PostgreSQL 9.4.x before 9.4.9
PostgreSQL 9.5.x before 9.5.4

Lösung

Update to the latest version
Get PostgreSQL

Folgen
?
OSI 
[?]

DoS 
[?]

CI 
[?]

PE 
[?]
CVE-IDS
?

Link zum Original