KLA10910
Multiple vulnerabilities in PostgreSQL
Обновлено: 17/06/2019
Дата обнаружения
09/12/2016
Уровень угрозы
High
Описание

Multiple serious vulnerabilities have been found in PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, 9.4.x before 9.4.9, and 9.5.x before 9.5.4. Malicious users can exploit these vulnerabilities to cause denial of service, obtain sensitive information, possibly execute arbitrary code or gain priveleges.

Below is a complete list of vulnerabilities:

  1. An unknown vulnerability can be exploited remotely via a specially crafted SQL statement to cause denial of service;
  2. An unknown vulnerability can be exploited remotely via a specially crafted SQL statement to obtain sensitive information or possibly execute arbitrary code;
  3. An unknown vulnerability can be exploited remotely by authenticated users with CREATEDB and CREATEROLE roles to gain superuser priveleges by using special characters in database or role names.

Technical details

Denial of service for vulnerability (1) occurs after NULL pointer dereference and server crash.

Specially crafted SQL statements for vulnerability (2) always contain CASE/WHEN commands or inline SQL function, which implements the equality operator requiring values of different types, used for a CASE expression.

Special characters for vulnerability (3) are double quote, backsplash, carriage return.

Пораженные продукты

PostgreSQL before 9.1.23
PostgreSQL 9.2.x before 9.2.18
PostgreSQL 9.3.x before 9.3.14
PostgreSQL 9.4.x before 9.4.9
PostgreSQL 9.5.x before 9.5.4

Решение

Update to the latest version
Get PostgreSQL

Оказываемое влияние
?
OSI 
[?]

DoS 
[?]

CI 
[?]

PE 
[?]
Связанные продукты
PostgreSQL
CVE-IDS