Kaspersky ID:
Detect Date:


Multiple serious vulnerabilities have been found in PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, 9.4.x before 9.4.9, and 9.5.x before 9.5.4. Malicious users can exploit these vulnerabilities to cause denial of service, obtain sensitive information, possibly execute arbitrary code or gain priveleges.

Below is a complete list of vulnerabilities:

  1. An unknown vulnerability can be exploited remotely via a specially crafted SQL statement to cause denial of service;
  2. An unknown vulnerability can be exploited remotely via a specially crafted SQL statement to obtain sensitive information or possibly execute arbitrary code;
  3. An unknown vulnerability can be exploited remotely by authenticated users with CREATEDB and CREATEROLE roles to gain superuser priveleges by using special characters in database or role names.

Technical details

Denial of service for vulnerability (1) occurs after NULL pointer dereference and server crash.

Specially crafted SQL statements for vulnerability (2) always contain CASE/WHEN commands or inline SQL function, which implements the equality operator requiring values of different types, used for a CASE expression.

Special characters for vulnerability (3) are double quote, backsplash, carriage return.

Original advisories

Related products

CVE list

  • CVE-2016-5424
  • CVE-2016-5423

Read more

Find out the statistics of the vulnerabilities spreading in your region on statistics.securelist.com

Found an inaccuracy in the description of this vulnerability? Let us know!
Kaspersky Next
Let’s go Next: redefine your business’s cybersecurity
Learn more
New Kaspersky!
Your digital life deserves complete protection!
Learn more
Confirm changes?
Your message has been sent successfully.