KLA10927
Denial of service vulnerabilities in PHP
Обновлено: 17/06/2019
Дата обнаружения
04/01/2017
Уровень угрозы
Critical
Описание

Multiple serious vulnerabilities have been found in PHP before 5.6.28 and PHP 7.x before 7.0.13. Malicious users can exploit these vulnerabilities to cause a denial of service. Other unspecified impacts are also possible.

Below is a complete list of vulnerabilities:

  1. NULL pointer dereference in ext/wddx/wddx.c can be exploited remotely via specially designed data in a wddxPacket XML document to cause a denial of service;
  2. Stack consumption vulnerability in the GD Graphics Library (libgd) can be exploited remotely via specially designed imagefilltoborder call which forces usage of a negative color value to cause a denial of service;
  3. Integer signedness error in the GD Graphics Library (libgd) can be exploited remotely via specially designed imagecreatefromstring call to cause a denial of service.

Technical details

Vulnerability (2) occurs in the gdImageFillToBorder function in gd.c file from the GD Graphics Library.

Vulnerability (3) occurs in the dynamicGetbuf function in gd_io_dp.c from the GD Graphics Library.

Пораженные продукты

PHP before 5.6.28
PHP 7.x before 7.0.13

Решение

Update to the latest versions
Download PHP

Первичный источник обнаружения
PHP 5 ChangeLog
PHP 7 ChangeLog
Оказываемое влияние
?
DoS 
[?]
Связанные продукты
PHP
CVE-IDS
CVE-2016-86707.5Critical
CVE-2016-99345.0Critical
CVE-2016-99335.0Critical