ESTE SERVICIO PUEDE CONTENER TRADUCCIONES DE GOOGLE. GOOGLE NIEGA CUALQUIER RESPONSABILIDAD RELACIONADA CON LAS TRADUCCIONES, EXPRESA O IMPLÍCITA, INCLUYENDO CUALQUIER RESPONSABILIDAD ACERCA DE LA PRECISIÓN, LA CONFIABILIDAD Y CUALQUIER RESPONSABILIDAD IMPLÍCITA DE COMERCIABILIDAD, IDONEIDAD PARA UN PROPÓSITO EN PARTICULAR Y DE NO INFRACCIÓN.

Por su comodidad, se ha traducido el sitio web de Kaspersky Lab utilizando un software de traducción de Google Translate. Se hicieron unos esfuerzos razonables para proporcionar una traducción precisa; no obstante, las traducciones automáticas no son perfectas y no hay ninguna intención de sustituir el trabajo de los traductores. Se proporcionan estas traducciones como un servicio para los usuarios del sitio web de Kaspersky Lab y se han publicado tal "como es". No hay ninguna garantía, expresa o implícita, acerca de la precisión, la confiabilidad o exactitud de cualquier traducción desde el inglés a cualquier otro idioma. La traducción de algunos contenidos (imágenes, videos, Flash, etc) podrían no ser totalmente fiel debido a las limitaciones del software de traducción.

KLA10927
Denegación de vulnerabilidades del servicio en PHP
Actualizado: 07/05/2018
Fecha de detección
?
01/04/2017
Nivel de gravedad
?
Crítica
Descripción

Se han encontrado múltiples vulnerabilidades serias en PHP antes de 5.6.28 y PHP 7.x antes de 7.0.13. Los usuarios malintencionados pueden explotar estas vulnerabilidades para causar una denegación de servicio. Otros impactos no especificados también son posibles.

A continuación hay una lista completa de vulnerabilidades:

  1. La desreferencia de punteros NULL en ext / wddx / wddx.c se puede explotar remotamente a través de datos especialmente diseñados en un documento wddxPacket XML para causar una denegación de servicio;
  2. La vulnerabilidad de consumo de pila en la Biblioteca de GD Graphics (libgd) puede explotarse de forma remota a través de la llamada imagefilltoborder especialmente diseñada, lo que obliga al uso de un valor de color negativo a provocar una denegación de servicio;
  3. El error de firma de enteros en la Biblioteca de GD Graphics (libgd) se puede explotar de forma remota a través de una llamada de creación de imagen creada especialmente para provocar una denegación de servicio.

Detalles técnicos

La vulnerabilidad (2) se produce en la función gdImageFillToBorder en el archivo gd.c de la Biblioteca de GD Graphics.

La vulnerabilidad (3) se produce en la función dynamicGetbuf en gd_io_dp.c desde la Biblioteca de GD Graphics.

Productos afectados

PHP antes de 5.6.28
PHP 7.x antes de 7.0.13

Solución

Actualización a las últimas versiones
Descargar PHP

Notas informativas originales

PHP 5 ChangeLog
PHP 7 ChangeLog

Impactos
?
DoS 
[?]
Productos relacionados
PHP
CVE-IDS
?

CVE-2016-8670
CVE-2016-9933
CVE-2016-9934


Enlace al original