DIESER SERVICE KANN ÜBERSETZUNGEN VON GOOGLE ENTHALTEN. GOOGLE ÜBERNIMMT KEINERLEI VERANTWORTUNG FÜR DIE ÜBERSETZUNGEN. DARUNTER FÄLLT JEGLICHE VERANTWORTUNG IN BEZUG AUF RICHTIGKEIT UND ZUVERLÄSSIGKEIT SOWIE JEGLICHE STILLSCHWEIGENDEN GEWÄHRLEISTUNGEN DER MARKTGÄNGIGKEIT, NICHT-VERLETZUNG VON RECHTEN DRITTER ODER DER EIGNUNG FÜR EINEN BESTIMMTEN ZWECK.

Die Website von Kaspersky Lab wurde für Ihre Bequemlichkeit mithilfe einer Übersetzungssoftware von Google Translate übersetzt. Es wurden angemessene Bemühungen für die Bereitstellung einer akkuraten Übersetzung unternommen. Bitte beachten Sie, dass automatisierte Übersetzungen nicht perfekt sind und menschliche Übersetzer in keinem Fall ersetzen sollen. Übersetzungen werden den Nutzern der Kaspersky-Lab-Website als Service und "wie sie sind" zur Verfügung gestellt. Die Richtigkeit, Zuverlässigkeit oder Korrektheit jeglicher Übersetzungen aus dem Englischen in eine andere Sprache wird weder ausdrücklich noch stillschweigend garantiert. Einige Inhalte (z. B. Bilder, Videos, Flash, usw.) können aufgrund der Einschränkungen der Übersetzungssoftware möglicherweise nicht inhaltsgetreu übersetzt werden.

KLA10927
Denial of service vulnerabilities in PHP
Aktualisiert: 03/29/2019
Erkennungsdatum
?
01/04/2017
Schweregrad
?
Kritisch
Beschreibung

Multiple serious vulnerabilities have been found in PHP before 5.6.28 and PHP 7.x before 7.0.13. Malicious users can exploit these vulnerabilities to cause a denial of service. Other unspecified impacts are also possible.

Below is a complete list of vulnerabilities:

  1. NULL pointer dereference in ext/wddx/wddx.c can be exploited remotely via specially designed data in a wddxPacket XML document to cause a denial of service;
  2. Stack consumption vulnerability in the GD Graphics Library (libgd) can be exploited remotely via specially designed imagefilltoborder call which forces usage of a negative color value to cause a denial of service;
  3. Integer signedness error in the GD Graphics Library (libgd) can be exploited remotely via specially designed imagecreatefromstring call to cause a denial of service.

Technical details

Vulnerability (2) occurs in the gdImageFillToBorder function in gd.c file from the GD Graphics Library.

Vulnerability (3) occurs in the dynamicGetbuf function in gd_io_dp.c from the GD Graphics Library.

Beeinträchtigte Produkte

PHP before 5.6.28
PHP 7.x before 7.0.13

Lösung

Update to the latest versions
Download PHP

Ursprüngliche Informationshinweise

PHP 5 ChangeLog
PHP 7 ChangeLog

Folgen
?
DoS 
[?]
CVE-IDS
?
CVE-2016-86707.5Critical
CVE-2016-99345.0Critical
CVE-2016-99335.0Critical

Link zum Original