KLA11110
Multiple vulnerabilities in VMware products
Updated: 08/17/2018
CVSS
?
7.2
Detect date
?
09/14/2017
Severity
?
High
Description

Multiple serious vulnerabilities have been found in VMware products. Malicious users can exploit these vulnerabilities to cause denial of service, privelege escalation, cross site scripting and arbitary code execution.

Below is a complete list of vulnerabilities :

  1. Out-of-bounds write vulnerability in SVGA device can be exploited to execute arbitrary code;
  2. Guest RPC NULL pointer dereference vulnerability can be exploited to cause denial of service;
  3. Stored XSS in H5 Client can be exploited to perform cross site scripting.

Technical details

Vulnerabilities 1 and 2 are related to VMware Workstation Pro, VMware Workstation Player, VMware ESXi and VMware Fusion

Vulnerabilities 3 are related to VMware vCenter Server

Affected products

Workstation 12 versions earlier than 12.5.7
Fusion 8 versions earlier than 8.5.8
vCenter Server version 6.5 without patch 6.5 U1
vCenter Server version 6.0, 5.5

Solution

Update to latest versions
Download VMware Fusion
Download VMware Workstation Pro
Download VMware vCenter Server

Original advisories

VMSA-2017-0015

Impacts
?
ACE 
[?]

DoS 
[?]

XSSCSS 
[?]
CVE-IDS
?

CVE-2017-4924
CVE-2017-4925
CVE-2017-4926