KLA11589
Multiple vulnerabilities in Mozilla Firefox
Обновлено: 22/05/2020
Дата обнаружения
22/10/2019
Уровень угрозы
Critical
Описание

Multiple vulnerabilities were found in Mozilla Firefox. Malicious users can exploit these vulnerabilities to bypass security restrictions, cause denial of service, gain privileges, execute arbitrary code.

Below is a complete list of vulnerabilities:

  1. Vulnerability can be exploited to bypass security restrictions;
  2. Use-after-free vulnerability can be exploited to cause denial of service;
  3. Vulnerability related to CSP can be exploited to bypass security restrictions;
  4. A Vulnerability can be exploited to cause denial of service;
  5. Stack buffer overflow vulnerability can be exploited to cause denial of service;
  6. Heap buffer overflow vulnerability can be exploited to cause denial of service;
  7. A Vulnerability can be exploited to gain privileges;
  8. Vulnerability related to document.domain can be exploited to execute arbitrary code;
  9. Buffer overflow vulnerability in expat can be exploited to arbitrary code execution;
  10. Memory safety vulnerability can be exploited to execute arbitrary code;
  11. Vulnerability related to HTML parsing can be exploited remotely to bypass security restrictions;
Пораженные продукты

Mozilla Firefox earlier than 70

Решение

Update to the latest version
Download Mozilla Firefox

Первичный источник обнаружения
Advisory 2019-34
Оказываемое влияние
?
ACE 
[?]

DoS 
[?]

SB 
[?]

PE 
[?]
Связанные продукты
Mozilla Firefox
CVE-IDS
CVE-2018-61560.0Unknown
CVE-2019-159030.0Unknown
CVE-2019-117610.0Unknown
CVE-2019-117570.0Unknown
CVE-2019-170010.0Unknown
CVE-2019-170020.0Unknown
CVE-2019-117600.0Unknown
CVE-2019-117650.0Unknown
CVE-2019-117590.0Unknown
CVE-2019-117620.0Unknown
CVE-2019-170000.0Unknown
CVE-2019-117640.0Unknown
CVE-2019-117630.0Unknown