KLA11589
Multiple vulnerabilities in Mozilla Firefox
Updated: 07/17/2020
Detect date
?
10/22/2019
Severity
?
Critical
Description

Multiple vulnerabilities were found in Mozilla Firefox. Malicious users can exploit these vulnerabilities to cause denial of service, execute arbitrary code, bypass security restrictions, gain privileges, spoof user interface.

Below is a complete list of vulnerabilities:

  1. Heap buffer overflow vulnerability can be exploited to cause denial of service;
  2. Unspecified vulnerability in libexpat can be exploited remotely via specially designed XML-file to obtain sensitive information;
  3. Vulnerability can be exploited to bypass security restrictions;
  4. Use-after-free vulnerability can be exploited to cause denial of service;
  5. Vulnerability related to CSP can be exploited to bypass security restrictions;
  6. A Vulnerability can be exploited to cause denial of service;
  7. Stack buffer overflow vulnerability can be exploited to cause denial of service;
  8. A Vulnerability can be exploited to gain privileges;
  9. Vulnerability related to document.domain can be exploited to execute arbitrary code;
  10. Memory safety vulnerability can be exploited to execute arbitrary code;
  11. Vulnerability related to HTML parsing can be exploited remotely to bypass security restrictions;
  12. Vulnerability in history api can be exploited remotely to spoof user interface.
Affected products

Mozilla Firefox earlier than 70

Solution

Update to the latest version
Download Mozilla Firefox

Original advisories

Advisory 2019-34

Impacts
?
ACE 
[?]

DoS 
[?]

SB 
[?]

PE 
[?]

SUI 
[?]
Related products
Mozilla Firefox
CVE-IDS
?
CVE-2018-61560.0Unknown
CVE-2019-159030.0Unknown
CVE-2019-117610.0Unknown
CVE-2019-117570.0Unknown
CVE-2019-170010.0Unknown
CVE-2019-170020.0Unknown
CVE-2019-117600.0Unknown
CVE-2019-117650.0Unknown
CVE-2019-117590.0Unknown
CVE-2019-117620.0Unknown
CVE-2019-170000.0Unknown
CVE-2019-117640.0Unknown
CVE-2019-117630.0Unknown
CVE-2020-124120.0Unknown