KLA11164
Multiple vulnerabilities in VMware products
Updated: 11/06/2018
CVSS
?
7.2
Detect date
?
12/19/2017
Severity
?
High
Description

Multiple serious vulnerabilities have been found in VMware products. Malicious users can exploit these vulnerabilities to cause privelege escalation, cross site scripting and arbitrary code execution.

  1. A vulnerability, related with using VNC can be exploited remotely via sending specipic VNC packets to execute arbitrary code;
  2.  A vulnerability in ESXi Host Client component can be exploited remotely to perform cross site scripting;
  3. A vulnerability in VMware vCenter Server Appliance can be exploited remotely gain privileges.

Technical details

Vulnerability (1) is affected VMvare Workstation, VMvare Fusion and VMvare ESXi products

Vulnerability (3) is affected VMware ESXi

Vulnerability (3) is  affected VMware vCenter Server Appliance

NB: This vulnerability does not have any public CVSS rating, so rating can be changed by the time.

Affected products

Workstation versions earlier than 12.5.8
Fusion 8 versions earlier than 8.5.9
vCenter Server Appliance version 6.5 without patch 6.5 U1

Solution

Update to latest versions
Download VMware Fusion
Download VMware Workstation Pro
Download VMware vCenter Server

Original advisories

VMSA-2017-0015.2

Impacts
?
ACE 
[?]

PE 
[?]
Related products
VMware Workstation
VMware Fusion
VMware vCenter Server
CVE-IDS
?

CVE-2017-4933
CVE-2017-4940
CVE-2017-4941
CVE-2017-4943