KLA11066
Multiple vulnerabilities in Adobe Flash Player
Updated: 09/10/2018
CVSS
?
10.0
Detect date
?
07/11/2017
Severity
?
Critical
Description

Multiple serious vulnerabilities have been found in Adobe Flash Player versions earlier than 26.0.0.137. Malicious users can exploit these vulnerabilities to obtain sensitive information and execute arbitrary code.

Below is a complete list of vulnerabilities:

  1. A memory corruption vulnerability in the Action Script 2 BitmapData class can be exploited remotely to obtain sensitive information;
  2. A security bypass vulnerability related to the Flash API (which used in Internet Explorer) can be exploited remotely to obtain sensitive information;
  3. A memory corruption vulnerability in Action Script 3 raster data model can be exploited remotely to execute arbitrary code.


Technical details

Vulnerability (1) can lead to memory address disclosure.

Affected products

Adobe Flash Player versions earlier than 26.0.0.137

Solution

Update to the latest versions
Download Adobe Flash Player

Original advisories

Adobe Security Bulletin

Impacts
?
ACE 
[?]

OSI 
[?]
Related products
Adobe Flash Player ActiveX
Adobe Flash Player NPAPI
Adobe Flash Player PPAPI
CVE-IDS
?

CVE-2017-3080
CVE-2017-3099
CVE-2017-3100