KLA10900
Multiple vulnerabilities in Microsoft Edge and Microsoft Internet Explorer
Updated: 10/23/2017
CVSS
?
7.6
Detect date
?
11/08/2016
Severity
?
Critical
Description

Multiple serious vulnerabilities have been found in Microsoft Internet Explorer and Microsoft Edge. Malicious users can exploit these vulnerabilities to execute arbitrary code, spoof user interface or obtain sensitive information.

Below is a complete list of vulnerabilities

  1. An improper memory objects handling can be exploited remotely via a specially designed content to execute arbitrary code or obtain sensitive information;
  2. An improper RegEx handling at XSS filter can be exploited by logged in attacker via a specially designed application to obtain sensitive information;
  3. An improper memory objects handling at scripting engines can be exploited remotely via a specially designed content to execute arbitrary code;
  4. An improper HTTP content parse can be exploited remotely via a specially designed content to spoof user interface.

 

Affected products

Microsoft Edge
Microsoft Internet Explorer versions 9 through 11

Solution

Install necessary updates from the KB section, that are listed in your Windows Update (Windows Update usually can be accessed from the Control Panel)

Original advisories

MS16-129
MS16-142

Impacts
?
SUI 
[?]

ACE 
[?]

OSI 
[?]
Related products
Microsoft Internet Explorer
Microsoft Edge
CVE-IDS
?

CVE-2016-7227
CVE-2016-7209
CVE-2016-7208
CVE-2016-7204
CVE-2016-7203
CVE-2016-7202
CVE-2016-7201
CVE-2016-7200
CVE-2016-7199
CVE-2016-7198
CVE-2016-7196
CVE-2016-7195
CVE-2016-7239
CVE-2016-7240
CVE-2016-7241
CVE-2016-7242
CVE-2016-7243

Microsoft official advisories
MS16-129
MS16-142
KB list

3198586
3200970
3198467
3198585
3199057
3197868
3197867
3197877
3197876
3197655
3197873
3197874
3205386
3208481
3205383
3203621
3205401
3205400
3205408
3205409
3207752
3205394