KLA10817
Privilege escalation in cURL
Updated: 06/01/2019
Detect date
?
05/29/2016
Severity
?
High
Description

An improper DLL loading was found in cURL. By exploiting this vulnerability malicious users can gain privileges. This vulnerability can be exploited via a DLL hijack.


Technical details

This vulnertability related to load of security.dll, secur32.dll and ws2_32.dll

Affected products

cURL and libcurl versions earlier than 7.49.1

Solution

Update to the latest version
cURL download page

Original advisories

Original advisory

Impacts
?
PE 
[?]
CVE-IDS
?