KLA10761
Multiple vulnerabilities in PostgreSQL
Updated: 06/01/2019
Detect date
?
02/17/2016
Severity
?
Critical
Description

Multiple serious vulnerabilities have been found in PostgreSQL. Malicious users can exploit these vulnerabilities to cause denial of service or gain privileges.

Below is a complete list of vulnerabilities

  1. An unknown vulnerability can be exploited remotely via a specially designed regular expression to cause denial of service;
  2. Improper access restrictions can be exploited to gain privileges.

Technical details

Exploitation of vulnerability (1) leads to infinite loop or buffer overflow and can be triggered via large Unicode characters range in regexp.

Vulnerability (2) related to lack of restrictions access to unspecified custom configuration services for PLJava.

Affected products

PostgreSQL versions earlier than 9.1.20
PostgreSQL 9.2 versions earlier than 9.2.15
PostgreSQL 9.3 versions earlier than 9.3.11
PostgreSQL 9.4 versions earlier than 9.4.6
PostgreSQL 9.5 versions earlier than 9.5.1

Solution

Update to the latest version
Get PostgreSQL

Impacts
?
DoS 
[?]

PE 
[?]
CVE-IDS
?
CVE-2016-07735.0Critical
CVE-2016-07669.0Critical