BU SERVİS, GOOGLE TARAFINDAN SAĞLANAN ÇEVİRİLER İÇEREBİLİR. GOOGLE, HERHANGİ BİR GARANTİ, GÜVENİLİRLİK VE TİCARİ ELVERİŞLİLİK, BELİRLİ BİR AMACA UYGUNLUK VE İHLAL ETMEME GARANTİLERİ DAHİL OLMAK ÜZERE AÇIK VEYA ZIMNİ GARANTİLER DE DAHİL OLMAK ÜZERE, AÇIK VEYA ZIMNİ TÜM GARANTİLERİ REDDEDER.

Kaspersky Lab web sitesi, Google Çeviri tarafından desteklenen çeviri yazılımı kullanılarak size kolaylık sağlamak amacıyla tercüme edilmiştir. Doğru bir çeviri sağlamak için makul çabalar sarf edilmiştir, ancak otomatik çeviri mükemmel değildir ve insan çevirmenlerinin yerini alması amaçlanmamıştır. Çeviriler, Kaspersky Lab web sitesinin kullanıcılarına bir hizmet olarak sunulur ve "olduğu gibi" sağlanır. İngilizce'den başka bir dile çevrilmiş herhangi bir çevirinin doğruluğu, güvenilirliği veya doğruluğu konusunda açık ya da zımni hiçbir garanti verilmemektedir. Çeviri yazılımı sınırlamaları nedeniyle bazı içerikler (görüntüler, videolar, Flash vb. Gibi) doğru bir şekilde çevrilemeyebilir.

KLA11206
Mozilla Firefox ve Firefox ESR'deki birden fazla güvenlik açığı
Yüklendi : 07/05/2018
Bulunma tarihi
?
03/13/2018
Şiddet
?
Kritik
Açıklama

Mozilla Firefox ve Mozilla Firefox ESR'de birden fazla ciddi güvenlik açığı bulundu. Kötü amaçlı kullanıcılar, hizmet reddi, kullanıcı arabirimi sızması, hassas bilgiler edinme, isteğe bağlı kod çalıştırma, siteler arası komut dosyası saldırıları yapma ve güvenlik kısıtlamalarını atlatma amacıyla bu güvenlik açıklarından yararlanabilir.

Aşağıda güvenlik açıklarının tam listesi:

  1. Tampon taşması güvenlik açığı, SVG animatedPathSegList komutunu kullanarak hizmet reddine neden olmak için uzaktan kumanda edilebilir;
  2. Hizmetten kaldırmaya neden olmak için ücretsiz bir güvenlik açığından yararlanılabilir;
  3. IPC messegas parametrelerindeki belirtilmemiş bir güvenlik açığı hizmet reddine neden olmak için uzaktan kullanılabilir.
  4. WebRTC bağlantılarındaki belirlenmemiş bir güvenlik açığı hizmet reddine neden olmak için uzaktan kullanılabilir.
  5. Fetch () API'sindeki belirlenmemiş bir güvenlik açığı güvenlik kısıtlamalarını atlamak için uzaktan kullanılabilir.
  6. WebExtensions için Bul API'sinde belirlenmemiş bir güvenlik açığı, hassas bilgiler elde etmek için uzaktan kullanılabilir.
  7. App.support.baseURL tercihinin değiştirilmesine ilişkin belirlenemeyen bir güvenlik açığı çapraz site komut dosyası (XSS) saldırısı gerçekleştirmek için uzaktan kullanılabilir.
  8. WebExtensions'daki belirlenmemiş bir güvenlik açığı, güvenlik kısıtlamalarını atlamak için uzaktan kullanılabilir.
  9. WebExtensions'ta belirlenmemiş bir güvenlik açığı, çapraz site komut dosyası (XSS) saldırısı gerçekleştirmek için uzaktan kullanılabilir.
  10. Paylaşılan işçinin data: oluşturulmasına ilişkin belirlenmemiş bir güvenlik açığı data: URL, güvenlik kısıtlamalarını atlamak için uzaktan kullanılabilir.
  11. Aşırı uzun alan adıyla Android Özel Sekmesi'nde kötü amaçlı sitenin açılmasıyla ilgili bir sahtecilik güvenlik açığı, kullanıcı arabiriminin parodi için uzaktan kullanılabilir.
  12. moz-icon: ile ilgili belirlenemeyen bir güvenlik açığı moz-icon: protokol, hassas bilgileri elde etmek için uzaktan kullanılabilir;
  13. Push API bildirimlerindeki belirlenmemiş bir güvenlik açığı hizmet reddine neden olmak için uzaktan kullanılabilir;
  14. Media Capture ve Streams API izinleriyle ilgili belirlenmemiş bir güvenlik açığı, kullanıcı arabiriminin parodi için uzaktan kullanılabilir.
  15. javascript: kullanan URL'lerle ilgili belirlenmemiş bir güvenlik açığı javascript: çapraz site komut dosyası (XSS) saldırısı gerçekleştirmek için uzaktan kullanılabilir.
  16. Birden fazla bellek bozulması güvenlik açığı keyfi kod çalıştırmak için uzaktan kullanılabilir;
  17. Metnin bazı Unicode karakterlerine dönüştürülmesiyle ilgili bir tamsayı taşması güvenlik açığı hizmet reddine neden olmak için uzaktan kullanılabilir.

Teknik detaylar

Güvenlik açıkları (2), (6) – (15) sadece Mozilla Firefox'u etkiler.

Güvenlik açığı (17) yalnızca Mozilla Firefox ESR'yi etkiler.

Not: Bu güvenlik açığının kamuya açık CVSS değeri yoktur, bu nedenle derecelendirme zamana göre değiştirilebilir.

Etkilenmiş ürünler

Daha önce Mozilla Firefox versiyonları 59
Mozilla Firefox ESR sürümleri daha önce 52.7

Çözüm

En son sürüme güncelle
Mozilla Firefox ESR indirin
Mozilla Firefox'u İndirin

Orijinal öneriler

Mozilla Foundation Security Advisory 2018-06
Mozilla Foundation Security Advisory 2018-07

Etkiler
?
SUI 
[?]

ACE 
[?]

OSI 
[?]

XSSCSS 
[?]

SB 
[?]

DoS 
[?]
Alakalı ürünler
Mozilla Firefox ESR
Mozilla Firefox
CVE-IDS
?

CVE-2018-2145
CVE-2018-2144
CVE-2018-2125
CVE-2018-2126
CVE-2018-2143
CVE-2018-2142
CVE-2018-2141
CVE-2018-2140
CVE-2018-2138
CVE-2018-2137
CVE-2018-2136
CVE-2018-2135
CVE-2018-2134
CVE-2018-2133
CVE-2018-2132
CVE-2018-2131
CVE-2018-2130
CVE-2018-2129
CVE-2018-2128
CVE-2018-2127


Orijinaline link