BU SERVİS, GOOGLE TARAFINDAN SAĞLANAN ÇEVİRİLER İÇEREBİLİR. GOOGLE, HERHANGİ BİR GARANTİ, GÜVENİLİRLİK VE TİCARİ ELVERİŞLİLİK, BELİRLİ BİR AMACA UYGUNLUK VE İHLAL ETMEME GARANTİLERİ DAHİL OLMAK ÜZERE AÇIK VEYA ZIMNİ GARANTİLER DE DAHİL OLMAK ÜZERE, AÇIK VEYA ZIMNİ TÜM GARANTİLERİ REDDEDER.

Kaspersky Lab web sitesi, Google Çeviri tarafından desteklenen çeviri yazılımı kullanılarak size kolaylık sağlamak amacıyla tercüme edilmiştir. Doğru bir çeviri sağlamak için makul çabalar sarf edilmiştir, ancak otomatik çeviri mükemmel değildir ve insan çevirmenlerinin yerini alması amaçlanmamıştır. Çeviriler, Kaspersky Lab web sitesinin kullanıcılarına bir hizmet olarak sunulur ve "olduğu gibi" sağlanır. İngilizce'den başka bir dile çevrilmiş herhangi bir çevirinin doğruluğu, güvenilirliği veya doğruluğu konusunda açık ya da zımni hiçbir garanti verilmemektedir. Çeviri yazılımı sınırlamaları nedeniyle bazı içerikler (görüntüler, videolar, Flash vb. Gibi) doğru bir şekilde çevrilemeyebilir.

KLA11076
Oracle Java SE'de birden fazla güvenlik açığı
Yüklendi : 07/05/2018
Bulunma tarihi
?
07/19/2017
Şiddet
?
Yüksek
Açıklama

Oracle Java SE'de birden fazla ciddi güvenlik açığı bulundu. Kötü amaçlı kullanıcılar, ayrıcalıklar elde etmek, erişilebilir verileri okumak ve yazmak ve hizmet reddine neden olmak için bu güvenlik açıklarından yararlanabilir.

Aşağıda güvenlik açıklarının tam listesi:

  1. Java SE, Java SE Embedded ve JRockit'in 2B alt bileşenindeki belirlenmemiş bir güvenlik açığı, korumalı Java Web Start uygulamaları, korumalı Java uygulamaları veya hizmet reddine neden olmak için bir web hizmeti aracılığıyla belirtilen Bileşendeki API'lere veri sağlayarak uzaktan kullanılabilir. ;
  2. Java SE'nin Güvenlik alt bileşenindeki belirlenmemiş bir güvenlik açığı, bir kullanıcıyı ayrıcalıklar elde etmek için güvenilmeyen kod çalıştırmaya ikna ederek uzaktan kullanılabilir.
  3. Java SE ve Java SE Embedded'in Hotspot alt bileşenindeki belirlenmemiş bir güvenlik açığı, bir kullanıcıyı ayrıcalıklar elde etmek için güvenilmeyen kod çalıştırmaya ikna ederek uzaktan kullanılabilir;
  4. Java SE'nin Scripting alt bileşenindeki belirlenmemiş bir güvenlik açığı, korumalı Java Web Start uygulamaları, korumalı Java uygulamaları ya da tüm Java SE erişimli verilerine okuma / yazma erişimi sağlamak için bir web hizmeti aracılığıyla belirtilen Bileşendeki API'lere veri sağlayarak uzaktan kullanılabilir. ;
  5. Java SE ve Java SE Embedded'in Hotspot alt bileşenindeki belirlenmemiş bir güvenlik açığı, bir kullanıcının Java SE, Java SE Embedded tarafından erişilebilen bazı verilerine yazma erişimi sağlamak için güvenilmeyen kod çalıştırma konusunda ikna ederek uzaktan kullanılabilir.
  6. Java SE'nin JavaFX alt bileşenindeki birden fazla belirtilmemiş güvenlik açığı, bir kullanıcıyı ayrıcalıklar elde etmek için güvenilmeyen kod çalıştırmaya ikna ederek uzaktan kullanılabilir.
  7. Java SE ve Java SE Embedded kütüphanelerinin alt bileşeninde birden fazla belirtilmemiş güvenlik açığı, bir kullanıcıyı ayrıcalıklar elde etmek için güvenilmeyen kod çalıştırmaya ikna ederek uzaktan kullanılabilir;
  8. Java SE'nin ImageIO alt bileşenindeki belirlenmemiş bir güvenlik açığı, bir kullanıcıyı ayrıcalıklar elde etmek için güvenilmeyen kod çalıştırmaya ikna ederek uzaktan kullanılabilir;
  9. Java SE ve Java SE Embedded'in JAXP alt bileşenindeki birden fazla belirtilmemiş güvenlik açığı, bir kullanıcıyı ayrıcalıklar elde etmek için güvenilmeyen kod çalıştırmaya ikna ederek uzaktan kullanılabilir.
  10. Java SE ve Java SE Embedded'in RMI alt bileşenindeki belirlenmemiş bir güvenlik açığı, ayrıcalıklar elde etmek için bir Web hizmeti aracılığıyla belirtilen Bileşendeki API'lere verileri uzaktan sağlayarak kullanılabilir;
  11. Java Advanced Management Console'un Sunucu alt bileşenindeki birden fazla belirtilmemiş güvenlik açığı, bazı Java Advanced Management Console erişimli verilerine okuma / yazma erişimi sağlamak ve hizmet reddine neden olmak için bilinmeyen vektörler aracılığıyla uzaktan kullanılabilir.
  12. Java SE'nin Deployment alt bileşenindeki belirlenmemiş bir güvenlik açığı, bir kullanıcının Java SE erişilebilir verilerine bazılarına yazma erişimi sağlamak için güvenilmeyen kod çalıştırma konusunda ikna ederek uzaktan kullanılabilir.
  13. Java SE ve Java SE Embedded'in RMI alt bileşenindeki belirlenmemiş bir güvenlik açığı, bir kullanıcıyı ayrıcalıklar elde etmek için güvenilmeyen kod çalıştırmaya ikna ederek uzaktan kullanılabilir;
  14. Java SE, Java SE Embedded ve JRockit'in Serialization alt bileşenindeki belirlenmemiş bir güvenlik açığı, korumalı Java Web Start uygulamaları, korumalı Java uygulamaları veya hizmet reddine neden olmak için bir web hizmeti aracılığıyla belirtilen Bileşendeki API'lere veri sağlayarak uzaktan kullanılabilir. ;
  15. Java SE, Java SE Embedded ve JRockit'in Serialization alt bileşenindeki belirlenmemiş bir güvenlik açığı, bir kullanıcının hizmet reddine neden olmak için güvenilmeyen kod çalıştırmasına ikna ederek uzaktan kullanılabilir.
  16. Java SE'nin AWT alt bileşenindeki belirlenmemiş bir güvenlik açığı, bir kullanıcıyı ayrıcalıklar elde etmek için güvenilmeyen kod çalıştırmaya ikna ederek uzaktan kullanılabilir.
  17. Java SE, Java SE Embedded, JRockit'in JCE alt bileşenindeki birden fazla belirtilmemiş güvenlik açığı, korumalı Java Web Start uygulamaları, korumalı Java uygulamaları veya herhangi bir okuma erişimi sağlamak için bir web hizmeti aracılığıyla belirtilen Bileşendeki API'lere veri sağlayarak uzaktan kullanılabilir. Java SE, Java SE Gömülü, JRockit erişilebilir veriler;
  18. Java SE, Java SE Embedded, JRockit'in Güvenlik alt bileşenindeki belirlenmemiş bir güvenlik açığı, korumalı Java Web Start uygulamaları, korumalı Java uygulamaları veya ayrıcalıklar elde etmek için bir web hizmeti aracılığıyla belirtilen Bileşendeki API'lere veri sağlayarak uzaktan kullanılabilir;
  19. Java Advanced Management Console'un Sunucu alt bileşenindeki belirlenmemiş bir güvenlik açığı, bazı Java Advanced Management Console erişimli verilerine okuma erişimi sağlamak için bilinmeyen vektörler aracılığıyla uzaktan kullanılabilir;
  20. Java SE'nin Dağıtım alt bileşenindeki belirlenmemiş bir güvenlik açığı, ayrıcalıklar elde etmek için bilinmeyen vektörler aracılığıyla yerel olarak kullanılabilir;
  21. Java SE, Java SE Embedded, JRockit'in Güvenlik alt bileşenindeki birden fazla belirtilmemiş güvenlik açığı, korumalı Java Web Start uygulamaları, korumalı Java uygulamaları veya bir Web hizmeti aracılığıyla tüm bileşenlere API'lere veri sağlayarak uzaktan erişimden yararlanabilir. Java SE, Java SE Gömülü, JRockit erişilebilir veriler;
  22. Java SE ve Java SE Embedded'in Güvenlik alt bileşenindeki belirlenmemiş bir güvenlik açığı, bir kullanıcının Java SE ve Java SE Embedded tarafından erişilebilen bazı verilere erişimini okumak için güvenilmeyen kod çalıştırma konusunda ikna ederek uzaktan kullanılabilir.
  23. Java SE, Java SE Embedded, JRockit'in JAX-WS alt bileşenindeki belirlenmemiş bir güvenlik açığı, korumalı Java Web Start uygulamaları, korumalı Java uygulamaları veya bir Web hizmeti aracılığıyla veriyi okumak için bir Web hizmeti aracılığıyla API'lere veri sağlayarak uzaktan kullanılabilir. Java SE ve Java SE'nin bazı yerleşik verilerine erişebilir ve hizmet reddine neden olabilir;

Teknik detaylar

Güvenlik Açığı (20), Java Otomatik Güncelleştirmesinin etkinleştirildiği Java'nın dağıtımı için geçerlidir.

Not: Her güvenlik açığı CVSS derecesine sahip değildir, bu nedenle kümülatif CVSS derecelendirmesi temsilci olamaz.

Etkilenmiş ürünler

Oracle Java SE 6u151
Oracle Java SE 7u141
Oracle Java SE 8u131
Oracle Java SE Gömülü 8u131
Oracle JRockit R28.3.14
Oracle Java Gelişmiş Yönetim Konsolu 2.6

Çözüm

En son sürüme güncelle
Java SE'yi edinin

Orijinal öneriler

Oracle Critical Patch Update – July 2017

Etkiler
?
WLF 
[?]

RLF 
[?]

PE 
[?]

DoS 
[?]
Alakalı ürünler
Oracle JRockit
Oracle Java JRE 1.8.x
Oracle Java JRE 1.7.x
Oracle Java JDK 1.8.x
Oracle Java JDK 1.7.x
CVE-IDS
?

CVE-2017-10243
CVE-2017-10198
CVE-2017-10193
CVE-2017-10176
CVE-2017-10145
CVE-2017-10125
CVE-2017-10121
CVE-2017-10118
CVE-2017-10117
CVE-2017-10116
CVE-2017-10115
CVE-2017-10114
CVE-2017-10111
CVE-2017-10110
CVE-2017-10109
CVE-2017-10108
CVE-2017-10107
CVE-2017-10105
CVE-2017-10104
CVE-2017-10102
CVE-2017-10096
CVE-2017-10090
CVE-2017-10089
CVE-2017-10087
CVE-2017-10086
CVE-2017-10081
CVE-2017-10078
CVE-2017-10074
CVE-2017-10067
CVE-2017-10053


Orijinaline link