KLA11734
Multiple vulnerabilities in Opera
Обновлено: 18/06/2020
Дата обнаружения
12/12/2018
Уровень угрозы
Warning
Описание

Multiple vulnerabilities were found in Opera. Malicious users can exploit these vulnerabilities to cause denial of service, bypass security restrictions, execute arbitrary code, spoof user interface, obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. Use after free vulnerability in Skia component can be exploited remotely via special crafted webpage to potentially cause denial of service.
  2. Security vulnerability in Media component can be exploited remotely via special crafted webpage to bypass same origin policy.
  3. Data validation vulnerability in Shell Integration component can be exploited remotely via special crafted webpage to execute arbitrary code.
  4. Heap buffer overflow vulnerability in Blink component can be exploited remotely via special crafted webpage to potentially cause denial of service.
  5. Policy enforcement vulnerability in URL Formatter component can be exploited remotely via special crafted domain name to perform domain spoofing.
  6. Security vulnerability in Site Isolation component can be exploited remotely via special crafted webpage to bypass security restrictions.
  7. Policy enforcement vulnerability in Navigation component can be exploited remotely via special crafted webpage to bypass origin policy.
  8. Security UI vulnerability in Blink component can be exploited remotely via special crafted webpage to perform domain spoofing.
  9. Security UI in PDFium component can be exploited remotely via a special crafted PDF file to obtain sensitive information.
  10. Use after free vulnerability in WebAudio component can be exploited remotely via special crafted webpage to potentially cause denial of service.
  11. Use after free vulnerability in PDFium component can be exploited remotely via special crafted webpage to potentially cause denial of service.
  12. Policy enforcement vulnerability in Blink component can be exploited via special crafted extension to execute arbitrary code.
  13. Use after free vulnerability in Extensions component can be exploited remotely via special crafted webpage to potentially cause denial of service.
  14. Policy enforcement vulnerability in Blink can be exploited remotely via special crafted webpage to bypass origin policy.
  15. Security UI vulnerability in Navigation component can be exploited via special crafted webpage to perfrom domain spoofing.
  16. Out of bounds read vulnerability in V8 component can be exploited remotely via special crafted webpage to potentially cause denial of service.
  17. Use after free vulnerability in MediaRecorder component can be exploted remotely via special crafted webpage to potentially cause denial of service.
  18. Policy enforcement vulnerability in Proxy component can be exploited locally via special crafted file to obtain sensitive inforamtion.
  19. Security vulnerability in Extensions component can be exploited remotely via special crafted extension to execute arbitrary code.
  20. Use after free vulnerability in Blink component can be exploited via special crafted webpage to potentially cause denial of service.
  21. Security UI vulnerability in Navigation component can be exploited remotely via special crafted web page to execute arbitrary code.
  22. Policy enforcement vulnerability in Navigation component can be exploited remotely via special crafted webpage to perform domain spoofing.
  23. Security UI vulnerability in Navigation component can be exploited remotely via special crafted webpage to perform domain spoofing.
  24. Security UI vulnerability in Network Authentication component on Android can be exploited remotely via special crafted webpage to perform domain spoofing.
  25. Security UI vulnerability in Omnibox component can be exploited remotely via special crafted domain name to perform domain spoofing.
  26. Security UI vulnerability in URL Formatter component can be exploited remotely via special crafted domain name to perform domain spoofing.
  27. Out of bounds write vulnerability in V8 component can be exploited remotely via special crafted webpage to execute arbitrary code.
  28. Out of bounds write in V8Out of bounds write vulnerability in V8 component can be exploited remotely via special crafted webpage to execute arbitrary code.
  29. Policy enforcement vulnerability in Payments component can be exploited remotely via special crafted webpage to execute arbitrary code.
  30. Use after free vulnerability in PDFium component can be exploited remotely via special crafted file to potentially cause denial of service.
  31. Heap buffer overflow vulnerability in Skia component can be exploited remotely via special crafted webpage to potentially cause denial of service.
  32. Heap buffer overflow vulnerability in Canvas component remotely via special crafted webpage to potentially cause denial of service.
Эксплуатация

Malware exists for this vulnerability. Usually such malware is classified as Exploit. More details.

Пораженные продукты

Opera earlier than 58.0.3135.26

Решение

Update to the latest version
Download Opera

Первичный источник обнаружения
Changelog for Opera 58
Stable Channel Update for Desktop
Оказываемое влияние
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]

SUI 
[?]
Связанные продукты
Opera
CVE-IDS
CVE-2018-174800.0Unknown
CVE-2018-174810.0Unknown
CVE-2018-183350.0Unknown
CVE-2018-183360.0Unknown
CVE-2018-183370.0Unknown
CVE-2018-183380.0Unknown
CVE-2018-183390.0Unknown
CVE-2018-183400.0Unknown
CVE-2018-183410.0Unknown
CVE-2018-183420.0Unknown
CVE-2018-183430.0Unknown
CVE-2018-183440.0Unknown
CVE-2018-183450.0Unknown
CVE-2018-183460.0Unknown
CVE-2018-183470.0Unknown
CVE-2018-183480.0Unknown
CVE-2018-183490.0Unknown
CVE-2018-183500.0Unknown
CVE-2018-183510.0Unknown
CVE-2018-183520.0Unknown
CVE-2018-183530.0Unknown
CVE-2018-183540.0Unknown
CVE-2018-183550.0Unknown
CVE-2018-183560.0Unknown
CVE-2018-183570.0Unknown
CVE-2018-183580.0Unknown
CVE-2018-183590.0Unknown
CVE-2018-200700.0Unknown
CVE-2018-200650.0Unknown
CVE-2018-200680.0Unknown
CVE-2018-200690.0Unknown
CVE-2018-200710.0Unknown
CVE-2018-200670.0Unknown
CVE-2018-200660.0Unknown