KLA11732
Multiple vulnerabilities in Opera
Обновлено: 22/05/2020
Дата обнаружения
14/06/2018
Уровень угрозы
Warning
Описание

Multiple vulnerabilities were found in Opera. Malicious users can exploit these vulnerabilities to cause denial of service, obtain sensitive information, bypass security restrictions, perform cross-site scripting attack, spoof user interface, execute arbitrary code.

Below is a complete list of vulnerabilities:

  1. Memory access vulnerability in WebRTC component can be exploited remotely via special crafted webpage to potentially cause to denial of service.
  2. Text entry mode vulnerability in Views component can be exploited locally to potentially obtain sensitive information.
  3. Memory vulnerability in WebRTC component can be exploited remotely to potentially sensitive information.
  4. Mutability protection vulnerability in WebAssembly component can be exploited remotely via special crafted webpage to potentially cause denial of service.
  5. Policy vulnerability in WebUSB component can be exploited to bypass origin policy.
  6. uXSS vulnerability in WebKit component on iOS can be exploited remotely via special crafted webpage to perform domain spoofing.
  7. Use after free vulnerability in IndexDB component can be exploited remotely to potentially execute arbitrary code.
  8. Memory access vulnerability in WebRTC component can be exploited remotely via special crafted webpage to potentially cause denial of service.
  9. Memory access vulnerability in PDFium component can be exploited remotely to cause denial of service.
  10. Memory access vulnerability in V8 component can be exploited remotely via special crafted webpage to cause denial of service.
  11. URL spoof vulnerability in Omnibox component can be exploited remotely to perform domain spoofing.
  12. Memory access vulnerability in V8 component can be explooited remotely to cause denial of service.
  13. Heap buffer overflow vulnerability in Skia component can be exploited remotely via special crafted webpage to cause denial of service.
  14. Security bypass vulnerability in the debugger extension API in DevTools can be exploited to execute arbitrary code and bypass security restrictions.
  15. UI spoofing vulnerability in Blink component can be exploited remotely via special crafted webpage to perform domain spoofing.
  16. Type confusion vulnerability in Blink component can be exploited remotely via special crafted webpage to potentially cause denial of service.
  17. Information leak vulnerability in Blink component can be exploited remotely via special crafted webpage to obtain sensitive information and bypass security restrictions.
  18. Data validation vulnerability in Blink component can be exploited remotely via special crafted webpage to bypass same origin policy.
  19. Policy enforcement vulnerability in Extensions API component can be exploited remotely to bypass security restrictions.
  20. Use after free vulnerability in Blink component can be exploited remote;lly via special crafted webpage to cause denial of service.
  21. Security bypass in the debugger extension API component can be exploited to execute arbitrary code and bypass security restrictions.
  22. Information leak vulnerability in Blink component can be exploited remotely via special crafted webpage to obtain sensitive information and perform domain spoofing.
Пораженные продукты

Opera earlier than 54.0.2952.23

Решение

Update to the latest version
Download Opera

Первичный источник обнаружения
Changelog for Opera 54
Stable Channel Update for Desktop
Оказываемое влияние
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]

XSS/CSS 
[?]

SUI 
[?]
Связанные продукты
Opera
CVE-IDS
CVE-2018-61230.0Unknown
CVE-2018-61240.0Unknown
CVE-2018-61250.0Unknown
CVE-2018-61260.0Unknown
CVE-2018-61270.0Unknown
CVE-2018-61280.0Unknown
CVE-2018-61290.0Unknown
CVE-2018-61300.0Unknown
CVE-2018-61310.0Unknown
CVE-2018-61320.0Unknown
CVE-2018-61330.0Unknown
CVE-2018-61340.0Unknown
CVE-2018-61350.0Unknown
CVE-2018-61360.0Unknown
CVE-2018-61370.0Unknown
CVE-2018-61380.0Unknown
CVE-2018-61390.0Unknown
CVE-2018-61400.0Unknown
CVE-2018-61410.0Unknown
CVE-2018-61420.0Unknown
CVE-2018-61430.0Unknown
CVE-2018-61440.0Unknown
CVE-2018-61450.0Unknown
CVE-2018-61470.0Unknown