本サービスには一部、Googleの支援により翻訳されたコンテンツが含まれます。Googleは、明示または黙示を問わず、市場性、特定目的への適合性、ならびに非侵害の黙示的保証を含む、翻訳の精度、信頼性、正確性に関連するあらゆる点において保証しません。

Kaspersky Labの本Webサイトは、便宜上、Google Translateを搭載した翻訳ソフトウェアを利用して翻訳されています。正確な翻訳となるよう合理的な努力を払ってはおりますが、自動翻訳の正確性は完全ではなく、翻訳者(人間)による翻訳に代わるものとして意図されているものでもありません。翻訳はKaspersky Labの本Webサイトをご利用の皆様の利便性を図るためのものであり、「翻訳結果をそのまま」ご提供するものです。英語からその他言語への翻訳における精度、信頼性、正確性に関しては、明示または黙示を問わず、いかなる保証もなされません。翻訳ソフトウェアのため、コンテンツの一部(画像、動画、フラッシュ等)は正しく翻訳されない場合があります。

KLA11093
Foxit Readerの任意のコード実行脆弱性
更新日: 07/05/2018
検出日
?
08/17/2017
危険度
?
重要
説明

Foxit ReaderとFoxit PhantomPDFに複数の深刻な脆弱性が発見されました。悪意のあるユーザーは、これらの脆弱性を利用して任意のコードを実行する可能性があります。

以下に、脆弱性の完全な一覧を示します。

  1. saveAs Javaスクリプト関数内のユーザー提供データの不適切な検証は、特別に設計されたページまたはファイルを介してリモートから悪用され、任意のコードを実行できます。
  2. app.launchURLメソッドでシステムコールを実行する前にユーザー指定の文字列を不適切に検証すると、特別に設計されたページやファイルを使用してリモートから任意のコードを実行することができます。
  3. 不適切な検証脆弱性がリモートから悪用され、任意のコードを実行する可能性があります。

注:これらの脆弱性には公開CVSS格付けがないため、格付けはその時点までに変更することができます。

影響を受ける製品

Foxit Readerのバージョンから8.3.1.21155まで

解決法

最新バージョンへのアップデート
Foxit Readerをダウンロード
Foxit PhantomPDFをダウンロード

オリジナル勧告

ZDI-17-691
ZDI-17-718
ZDI-17-692

影響
?
ACE 
[?]
関連製品
Foxit Reader
Foxit Phantom PDF
CVE-IDS
?

CVE-2017-10953
CVE-2017-10952
CVE-2017-10951


オリジナルへのリンク