本サービスには一部、Googleの支援により翻訳されたコンテンツが含まれます。Googleは、明示または黙示を問わず、市場性、特定目的への適合性、ならびに非侵害の黙示的保証を含む、翻訳の精度、信頼性、正確性に関連するあらゆる点において保証しません。

Kaspersky Labの本Webサイトは、便宜上、Google Translateを搭載した翻訳ソフトウェアを利用して翻訳されています。正確な翻訳となるよう合理的な努力を払ってはおりますが、自動翻訳の正確性は完全ではなく、翻訳者(人間)による翻訳に代わるものとして意図されているものでもありません。翻訳はKaspersky Labの本Webサイトをご利用の皆様の利便性を図るためのものであり、「翻訳結果をそのまま」ご提供するものです。英語からその他言語への翻訳における精度、信頼性、正確性に関しては、明示または黙示を問わず、いかなる保証もなされません。翻訳ソフトウェアのため、コンテンツの一部(画像、動画、フラッシュ等)は正しく翻訳されない場合があります。

KLA10931
PHPにおけるサービス拒否の脆弱性
更新日: 07/05/2018
検出日
?
01/04/2017
危険度
?
緊急
説明

不特定の脆弱性が、5.3.29より前のPHP、5.4.30より前の5.4.x、および5.5.14より前の5.5.xで発見されました。この脆弱性を利用することで、悪意のあるユーザーがサービス拒否を引き起こす可能性があります。その他の不特定の影響も可能である。この脆弱性は、最初の引数が長いlocale_get_display_name呼び出しを介してリモートから悪用される可能性があります。


技術的な詳細

この脆弱性は、ext / intl / locale / locale_methods.cのget_icu_disp_value_src_php関数で発生します。

影響を受ける製品

PHP 5.3.29より前
PHP 5.4.x before 5.4.30
5.5.14より前のPHP 5.5.x

解決法

最新バージョンへのアップデート
PHPのダウンロード

オリジナル勧告

PHP Bugs

影響
?
DoS 
[?]
関連製品
PHP
CVE-IDS
?

CVE-2014-9912


オリジナルへのリンク