本サービスには一部、Googleの支援により翻訳されたコンテンツが含まれます。Googleは、明示または黙示を問わず、市場性、特定目的への適合性、ならびに非侵害の黙示的保証を含む、翻訳の精度、信頼性、正確性に関連するあらゆる点において保証しません。

Kaspersky Labの本Webサイトは、便宜上、Google Translateを搭載した翻訳ソフトウェアを利用して翻訳されています。正確な翻訳となるよう合理的な努力を払ってはおりますが、自動翻訳の正確性は完全ではなく、翻訳者(人間)による翻訳に代わるものとして意図されているものでもありません。翻訳はKaspersky Labの本Webサイトをご利用の皆様の利便性を図るためのものであり、「翻訳結果をそのまま」ご提供するものです。英語からその他言語への翻訳における精度、信頼性、正確性に関しては、明示または黙示を問わず、いかなる保証もなされません。翻訳ソフトウェアのため、コンテンツの一部(画像、動画、フラッシュ等)は正しく翻訳されない場合があります。

KLA10855
Apache OpenOfficeにおけるメモリ破損の脆弱性
更新日: 07/05/2018
検出日
?
07/21/2016
危険度
?
重要
説明

Apache OpenOffice Impressに不特定の脆弱性が見つかりました。この脆弱性を利用することにより、悪意のあるユーザーはサービス拒否を引き起こしたり、任意のコードを実行する可能性があります。この脆弱性は、特別に設計された.ODPおよび.OTPファイルを使用してリモートから悪用される可能性があります。


技術的な詳細

MetaActionを処理する際に悪用可能なアウトオブバウンドの脆弱​​性が発生します。

脆弱性はファイルに関連しています:

  1. maintoolssourcegenericpoly2.cxx(217〜230行目を参照)。
  2. mainvclsourcegdimetaact.cxx(1189行目を参照)。
影響を受ける製品

Apache OpenOfficeバージョン4.1.2以前
OpenOffice.orgのバージョン

解決法

信頼できないファイル内でApache OpenOffice Impressを使用しないでください。開発者がリリースするとすぐにアップデートをインストールしてください。詳細な手順については、元のアドバイザリを参照してください。

オリジナル勧告

Original Apache advisory

影響
?
ACE 
[?]

DoS 
[?]
関連製品
OpenOffice.org
Apache OpenOffice
CVE-IDS
?

CVE-2016-1513


オリジナルへのリンク