Searching
..

Click anywhere to stop

KLA61363
Multiple vulnerabilities in Apache Tomcat

Updated: 01/25/2024
Detect date
?
10/10/2023
Severity
?
High
Description

Multiple vulnerabilities were found in Apache Tomcat. Malicious users can exploit these vulnerabilities to cause denial of service, obtain sensitive information, execute arbitrary code.

Below is a complete list of vulnerabilities:

  1. A denial of service vulnerability in HTTP/2 protocol can be exploited remotely to cause denial of service.
  2. A denial of service vulnerability in FileUpload can be exploited remotely to cause denial of service.
  3. A information disclosure vulnerability can be exploited remotely to obtain sensitive information.
  4. A improper input validation vulnerability in HTTP trailer headers can be exploited to execute arbitrary code.
Exploitation

Public exploits exist for this vulnerability.

Malware exists for this vulnerability. Usually such malware is classified as Exploit. More details.

Affected products

Apache Tomcat 8.5.x earlier than 8.5.94
Apache Tomcat 9.x earlier than 9.0.81

Solution

Update to the latest version
Tomcat 9.0 Software Downloads
Tomcat 8.5 Software Downloads

Original advisories

Fixed in Apache Tomcat 9.0.81
Fixed in Apache Tomcat 8.5.94

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]
Related products
Apache Tomcat
CVE-IDS
?
Find out the statistics of the vulnerabilities spreading in your region