Searching
..

Click anywhere to stop

KLA61362
Multiple vulnerabilities in Apache Tomcat

Updated: 01/25/2024
Detect date
?
10/10/2023
Severity
?
High
Description

Multiple vulnerabilities were found in Apache Tomcat. Malicious users can exploit these vulnerabilities to execute arbitrary code, cause denial of service, obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. Improper Input Validation vulnerability in HTTP trailer headers can be exploited to execute arbitrary code.
  2. A denial of service vulnerability in HTTP/2 protocol can be exploited remotely to cause denial of service.
  3. information disclosure vulnerability can be exploited remotely to obtain sensitive information.
Exploitation

Public exploits exist for this vulnerability.

Malware exists for this vulnerability. Usually such malware is classified as Exploit. More details.

Affected products

Apache Tomcat 10.1.x earlier than 10.1.14

Solution

Update to the latest version
Tomcat 10.1 Software Downloads

Original advisories

Fixed in Apache Tomcat 10.1.14

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]
Related products
Apache Tomcat
CVE-IDS
?
Find out the statistics of the vulnerabilities spreading in your region