KLA52662
Multiple vulnerabilities in Mozilla Firefox ESR

Updated: 09/29/2023
Detect date
?
08/29/2023
Severity
?
High
Description

Multiple vulnerabilities were found in Mozilla Firefox ESR. Malicious users can exploit these vulnerabilities to execute arbitrary code, cause denial of service.

Below is a complete list of vulnerabilities:

  1. Memory corruption vulnerability in IPC CanvasTranslator can be exploited remotely to cause denial of service or execute arbitrary code.
  2. Memory corruption vulnerability in IPC ColorPickerShownCallback can be exploited remotely to cause denial of service or execute arbitrary code.
  3. Memory corruption vulnerability in IPC FilePickerShownCallback can be exploited remotely to cause denial of service or execute arbitrary code.
  4. Integer overflow vulnerability in RecordedSourceSurfaceCreation can be exploited to cause execute arbitrary code and denial of service.
  5. Code execution vulnerability can be exploited remotely to execute arbitrary code.
  6. Memory safety vulnerability can be exploited to execute arbitrary code.
Affected products

Mozilla Firefox ESR earlier than 102.15

Solution

Update to the latest version
Download Firefox ESR

Original advisories

MFSA2023-35

Impacts
?
ACE 
[?]

DoS 
[?]

SB 
[?]

PE 
[?]

SUI 
[?]
Related products
Mozilla Firefox ESR
CVE-IDS
?
CVE-2023-45815.0Warning
CVE-2023-45845.0Warning
CVE-2023-45765.0Warning
CVE-2023-45755.0Warning
CVE-2023-45735.0Warning
CVE-2023-45745.0Warning
Find out the statistics of the vulnerabilities spreading in your region