Searching
..

Click anywhere to stop

KLA49165
Multiple vulnerabilities in Mozilla Firefox

Updated: 01/25/2024
Detect date
?
05/09/2023
Severity
?
High
Description

Multiple vulnerabilities were found in Mozilla Firefox. Malicious users can exploit these vulnerabilities to cause denial of service, spoof user interface, execute arbitrary code, gain privileges, obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. Out of bounds vulnerability in RLBox Expat driver can be exploited to cause denial of service.
  2. Security UI vulnerability in Popups can be exploited to spoof user interface.
  3. Denial of service vulnerability in Content process can be exploited to cause denial of service.
  4. Memory corruption vulnerability in FileReader can be exploited remotely to cause denial of service or execute arbitrary code.
  5. Elevation of privilege vulnerability in Popup notifications can be exploited remotely to gain privileges.
  6. Denial of service vulnerability in Exposed protocol handlers can be exploited to cause denial of service.
  7. Memory safety vulnerability can be exploited to execute arbitrary code.
  8. Elevation of privilege vulnerability in Documents can be exploited remotely to gain privileges.
  9. Information disclosure vulnerability in Service workers can be exploited to obtain sensitive information.
  10. Security UI vulnerability in Address bar can be exploited to spoof user interface.
  11. Out of memory crash vulnerability in Favicon can be exploited to cause denial of service
Affected products

Mozilla Firefox earlier than 113.0

Solution

Update to the latest version
Download Firefox

Original advisories

MFSA2023-16

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]

PE 
[?]

SUI 
[?]
Related products
Mozilla Firefox
CVE-IDS
?
CVE-2023-322066.5High
CVE-2023-322054.3Warning
CVE-2023-322116.5High
CVE-2023-322138.8Critical
CVE-2023-322078.8Critical
CVE-2023-322147.5Critical
CVE-2023-322169.8Critical
CVE-2023-322106.5High
CVE-2023-322085.3High
CVE-2023-322158.8Critical
CVE-2023-322124.3Warning
CVE-2023-322097.5Critical
Find out the statistics of the vulnerabilities spreading in your region