Searching
..

Click anywhere to stop

KLA48551
Multiple vulnerabilities in Mozilla Firefox

Updated: 01/25/2024
Detect date
?
03/14/2023
Severity
?
High
Description

Multiple vulnerabilities were found in Mozilla Firefox. Malicious users can exploit these vulnerabilities to cause denial of service, execute arbitrary code, obtain sensitive information, spoof user interface.

Below is a complete list of vulnerabilities:

  1. Denial of service vulnerability in JIT compiler can be exploited to cause denial of service.
  2. Memory safety vulnerability can be exploited to execute arbitrary code.
  3. Information disclosure vulnerability in ServiceWorker can be exploited to obtain sensitive information.
  4. Denial of service vulnerability in Worklets can be exploited to cause denial of service.
  5. Information disclosure vulnerability in Web extension can be exploited to obtain sensitive information.
  6. Security UI vulnerability in Cross-origin iframe can be exploited to spoof user interface.
  7. Remote code execution vulnerability can be exploited remotely to execute arbitrary code.
  8. Security UI vulnerability in Fullscreen Notification can be exploited to spoof user interface.
  9. Information disclosure vulnerability in Save As dialog on Windows can be exploited to obtain sensitive information.
  10. Information disclosure vulnerability in Permissions system can be exploited to obtain sensitive information.
  11. Out of bounds vulnerability can be exploited to cause denial of service.
Affected products

Mozilla Firefox earlier than 111.0

Solution

Update to the latest version
Download Firefox

Original advisories

MFSA2023-09

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]

SUI 
[?]
Related products
Mozilla Firefox
CVE-IDS
?
Find out the statistics of the vulnerabilities spreading in your region