KLA20166
Multiple vulnerabilities in Oracle Java SE and GraalVM

Updated: 01/18/2023
Detect date
?
01/17/2023
Severity
?
Warning
Description

Multiple vulnerabilities were found in Oracle Java SE and GraalVM. Malicious users can exploit these vulnerabilities to cause denial of service, execute arbitrary code.

Below is a complete list of vulnerabilities:

  1. Denial of service vulnerability in JSSE can be exploited to cause denial of service.
  2. Code execution vulnerability in Sound can be exploited to execute arbitrary code.
  3. Code execution vulnerability in Serialization can be exploited to execute arbitrary code.
Affected products

Oracle GraalVM Enterprise Edition 20.3.8, 21.3.4, 22.3.0

Oracle Java SE 8u351, 11.0.17, 17.0.5, 19.0.1

Solution

Update to the latest version
Download Java

Original advisories

Oracle Critical Patch Update Advisory – January 2023

Impacts
?
ACE 
[?]

DoS 
[?]
Related products
Oracle Java JRE 1.7.x
Oracle Java JRE 1.8.x
Find out the statistics of the vulnerabilities spreading in your region