Searching
..

Click anywhere to stop

KLA20151
Multiple vulnerabilities in Adobe Acrobat and Adobe Acrobat Reader

Updated: 01/25/2024
Detect date
?
01/10/2023
Severity
?
Critical
Description

Multiple vulnerabilities were found in Adobe Acrobat and Adobe Acrobat Reader. Malicious users can exploit these vulnerabilities to cause denial of service, execute arbitrary code, gain privileges, obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. Null Pointer Dereference vulnerability can be exploited to cause denial of service.
  2. Use after free vulnerability can be exploited to cause execute arbitrary code.
  3. Elevation of privilege vulnerability can be exploited remotely to gain privileges.
  4. Out of bounds write vulnerability can be exploited to cause execute arbitrary code.
  5. Stack-based buffer overflow vulnerability can be exploited to execute arbitrary code.
  6. Heap buffer overflow vulnerability can be exploited to cause denial of service.
  7. Integer overflow vulnerability can be exploited to cause execute arbitrary code.
  8. Out of bounds read vulnerability can be exploited to cause obtain sensitive information.
  9. Input validation vulnerability can be exploited to execute arbitrary code.
  10. Out of bounds write vulnerability can be exploited to execute arbitrary code.
Exploitation

Public exploits exist for this vulnerability.

Malware exists for this vulnerability. Usually such malware is classified as Exploit. More details.

Affected products

Adobe Acrobat DC Continuous earlier than 22.003.20310
Adobe Acrobat Reader DC Continuous earlier than 22.003.20310
Adobe Acrobat 2020 Classic earlier than 20.005.30436
Adobe Acrobat Reader 2020 Classic earlier than 20.005.30436

Solution

Update to the latest version
Download Adobe Acrobat Reader DC

Original advisories

APSB23-01

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]

PE 
[?]
Related products
Adobe Acrobat Reader DC Continuous
Adobe Acrobat DC Continuous
Adobe Acrobat Reader 2020
Adobe Acrobat 2020
CVE-IDS
?
CVE-2023-216087.8Critical
CVE-2023-216117.8Critical
CVE-2023-216067.8Critical
CVE-2023-216097.8Critical
CVE-2023-216047.8Critical
CVE-2023-216107.8Critical
CVE-2023-216057.8Critical
CVE-2023-215797.8Critical
CVE-2023-216127.8Critical
CVE-2023-215815.5High
CVE-2023-216135.5High
CVE-2023-215855.5High
CVE-2023-216145.5High
CVE-2023-216077.8Critical
CVE-2023-222417.8Critical
CVE-2023-222427.8Critical
CVE-2023-222407.8Critical
Find out the statistics of the vulnerabilities spreading in your region