KLA20049
Multiple vulnerabilities in Mozilla Firefox

Updated: 11/16/2022
Detect date
?
11/15/2022
Severity
?
High
Description

Multiple vulnerabilities were found in Mozilla Firefox. Malicious users can exploit these vulnerabilities to cause denial of service, spoof user interface, bypass security restrictions, obtain sensitive information, execute arbitrary code, gain privileges, perform cross-site scripting attack.

Below is a complete list of vulnerabilities:

  1. Denial of service vulnerability in Symlinks can be exploited cause denial of service.
  2. Security UI vulnerability in Custom cursor can be exploited to spoof user interface.
  3. Use after free vulnerability in expat can be exploited to cause denial of service.
  4. Security vulnerability in TLS certificate can be exploited to bypass security restrictions.
  5. Information disclosure vulnerability in Side-Channel can be exploited to obtain sensitive information.
  6. Use after free vulnerability in JavaScript Realm can be exploited to cause denial of service or execute arbitrary code.
  7. Security vulnerability in Service Workers area can be exploited to bypass security restrictions.
  8. Security UI vulnerability in window.print can be exploited to spoof user interface.
  9. Elevation of privilege vulnerability in S.browser_fallback_url can be exploited remotely to gain privileges.
  10. Information disclosure vulnerability in Service Workers can be exploited to obtain sensitive information.
  11. Use after free vulnerability in FontFace can be exploited to cause denial of service.
  12. Security bypass vulnerability in Trace can be exploited to perform cross-site scripting attack.
  13. Security UI vulnerability in windowName can be exploited to spoof user interface.
  14. Security UI vulnerability in iframe can be exploited to spoof user interface.
  15. Use after free vulnerability in InputStream can be exploited to cause denial of service or execute arbitrary code.
  16. Use after free vulnerability in Garbage Collection can be exploited to cause denial of service or execute arbitrary code.
  17. Code execution vulnerability can be exploited to execute arbitrary code.
  18. Memory safety vulnerability can be exploited to execute arbitrary code.
Affected products

Mozilla Firefox earlier than 107.0

Solution

Update to the latest version
Download Firefox

Original advisories

MFSA2022-47

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]

PE 
[?]

XSS/CSS 
[?]

SUI 
[?]
Related products
Mozilla Firefox
CVE-IDS
?
CVE-2022-406745.0Critical
Find out the statistics of the vulnerabilities spreading in your region