KLA20013
Multiple vulnerabilities in Oracle Java SE and GraalVM

Updated: 10/20/2022
Detect date
?
10/18/2022
Severity
?
Critical
Description

Multiple vulnerabilities were found in Oracle Java SE and GraalVM. Malicious users can exploit these vulnerabilities to execute arbitrary code, gain privileges, cause denial of service.

Below is a complete list of vulnerabilities:

  1. An elevation of privilege vulnerability in Networking can be exploited remotely to gain privileges and execute arbitrary code.
  2. A denial of service vulnerability in Lightweight HTTP Server can be exploited to cause denial of service and execute arbitrary code.
  3. An elevation of privilege vulnerability in JNDI can be exploited remotely to gain privileges and execute arbitrary code.
  4. An elevation of privilege vulnerability in JGSS can be exploited remotely to gain privileges and execute arbitrary code.
  5. An elevation of privilege vulnerability in Security can be exploited remotely to gain privileges and execute arbitrary code.
  6. A denial of service vulnerability in Security can be exploited to cause denial of service and execute arbitrary code.
Affected products

Oracle GraalVM Enterprise Edition 20.3.7, 21.3.3, 22.2.0

Oracle Java SE 8u341, 11.0.16.1, 17.0.4.1, 19

Solution

Update to the latest version
Download Java

Original advisories

Oracle Critical Patch Update Advisory – October 2022

Impacts
?
ACE 
[?]

DoS 
[?]

SB 
[?]

PE 
[?]
Related products
Oracle Java JRE 1.7.x
Oracle Java JRE 1.8.x
CVE-IDS
?
CVE-2022-393995.0Critical
CVE-2022-216285.0Critical
CVE-2022-216245.0Critical
CVE-2022-216185.0Critical
CVE-2022-216195.0Critical
CVE-2022-216265.0Critical
Find out the statistics of the vulnerabilities spreading in your region