KLA15726
Multiple vulnerabilities in Mozilla Firefox

Updated: 08/24/2022
Detect date
?
08/23/2022
Severity
?
High
Description

Multiple vulnerabilities were found in Mozilla Firefox. Malicious users can exploit these vulnerabilities to execute arbitrary code, bypass security restrictions, obtain sensitive information, spoof user interface.

Below is a complete list of vulnerabilities:

  1. Memory safety vulnerability can be exploited to execute arbitrary code.
  2. Security bypass vulnerability in a zero-length JavaScript array can be exploited to bypass security restrictions.
  3. Security bypass vulnerability in iframe can be exploited to bypass security restrictions.
  4. Security UI vulnerability in XSLT error handling can be exploited to spoof user interface and obtain sensitive information.
  5. Security bypass vulnerability in permissions on Android can be exploited to bypass security restrictions.
Affected products

Mozilla Firefox earlier than 104.0

Solution

Update to the latest version
Download Firefox

Original advisories

MFSA2022-33

Impacts
?
ACE 
[?]

OSI 
[?]

SB 
[?]

SUI 
[?]
Related products
Mozilla Firefox
Find out the statistics of the vulnerabilities spreading in your region