KLA12588
Multiple vulnerabilities in Oracle Java SE and GraalVM

Updated: 07/21/2022
Detect date
?
07/19/2022
Severity
?
High
Description

Multiple vulnerabilities were found in Oracle Java SE and GraalVM. Malicious users can exploit these vulnerabilities to obtain sensitive information, execute arbitrary code, bypass security restrictions.

Below is a complete list of vulnerabilities:

  1. Information disclosure vulnerability can be exploited to obtain sensitive information.
  2. RCE vulnerability in Java XSLTcan be exploited to cause denial of service or execute arbitrary code.
  3. Security vulnerability can be exploited to bypass security restrictions.
Affected products

Oracle GraalVM Enterprise Edition 20.3.6, 21.3.2, 22.1.0

Oracle Java SE 7u343, 8u333, 11.0.15.1, 17.0.3.1, 18.0.1.1

Solution

Update to the latest version
Download Java

Original advisories

Oracle Critical Patch Update Advisory – July 2022

Impacts
?
ACE 
[?]

OSI 
[?]

SB 
[?]
Related products
Oracle Java JRE 1.7.x
Oracle Java JRE 1.8.x
CVE-IDS
?
CVE-2022-215405.0Critical
CVE-2022-341695.0Critical
CVE-2022-215495.0Critical
CVE-2022-215415.0Critical
Find out the statistics of the vulnerabilities spreading in your region