KLA12574
Multiple vulnerabilities in Mozilla Thunderbird

Updated: 06/29/2022
Detect date
?
06/28/2022
Severity
?
High
Description

Multiple vulnerabilities were found in Mozilla Thunderbird. Malicious users can exploit these vulnerabilities to execute arbitrary code, obtain sensitive information, cause denial of service, bypass security restrictions, gain privileges, spoof user interface.

Below is a complete list of vulnerabilities:

  1. A remote code execution vulnerability can be exploited to execute arbitrary code.
  2. Information disclosure vulnerability in OCSP requests can be exploited to obtain sensitive information.
  3. Use after free vulnerability in nsSHistory can be exploited to cause denial of service or execute arbitrary code.
  4. Security vulnerability can be exploited to bypass security restrictions.
  5. Denial of service vulnerability can be exploited to cause denial of service.
  6. An elevation of privilege vulnerability can be exploited remotely to gain privileges.
  7. A remote code execution vulnerability can be exploited remotely to execute arbitrary code.
  8. Integer underflow vulnerability in ReplaceElementsAt can be exploited to cause denial of service.
  9. Security UI vulnerability in cursor can be exploited to spoof user interface.
Affected products

Mozilla Thunderbird earlier than 91.11
Mozilla Thunderbird 102.x earlier than 102.0

Solution

Update to the latest version
Download Thunderbird

Original advisories

MFSA2022-26

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]

PE 
[?]

SUI 
[?]
Related products
Mozilla Thunderbird
Find out the statistics of the vulnerabilities spreading in your region