KLA12520
Multiple vulnerabilities in Mozilla Firefox

Updated: 05/16/2022
Detect date
?
05/03/2022
Severity
?
High
Description

Multiple vulnerabilities were found in Mozilla Firefox. Malicious users can exploit these vulnerabilities to execute arbitrary code, gain privileges, bypass security restrictions, spoof user interface, obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. Memory safety vulnerability can be exploited to execute arbitrary code.
  2. An elevation of privilege vulnerability in iframe Sandbox can be exploited remotely to gain privileges.
  3. Bypassing permission prompt in nested browsing contexts can be exploited to bypass security restrictions.
  4. Leaking cross-origin redirect can be exploited to bypass security restrictions.
  5. Fullscreen notification bypass using popups can be exploited to spoof user interface.
  6. Security vulnerability in reader mode can be exploited to bypass security restrictions.
  7. Security vulnerability can be exploited to bypass security restrictions.
  8. Leaking browser history with CSS variables can be exploited to obtain sensitive information.
Affected products

Mozilla Firefox earlier than 100.0

Solution

Update to the latest version
Download Firefox

Original advisories

MFSA2022-16

Impacts
?
ACE 
[?]

OSI 
[?]

SB 
[?]

PE 
[?]

SUI 
[?]
Related products
Mozilla Firefox
Find out the statistics of the vulnerabilities spreading in your region