KLA12474
Multiple vulnerabilities in Microsoft Developer Tools

Updated: 03/09/2022
Detect date
?
03/08/2022
Severity
?
High
Description

Multiple vulnerabilities were found in Microsoft Developer Tools. Malicious users can exploit these vulnerabilities to spoof user interface, execute arbitrary code, cause denial of service.

Below is a complete list of vulnerabilities:

  1. A spoofing vulnerability in Visual Studio Code can be exploited remotely to spoof user interface.
  2. A remote code execution vulnerability in .NET and Visual Studio can be exploited remotely to execute arbitrary code.
  3. A denial of service vulnerability in .NET and Visual Studio can be exploited remotely to cause denial of service.
  4. Buffer overflow vulnerability in Brotli library can be exploited to cause denial of service.
Affected products

Microsoft Visual Studio 2019 version 16.7 (includes 16.0 – 16.6)
.NET 6.0
.NET Core 3.1
Microsoft Visual Studio 2019 version 16.9 (includes 16.0 - 16.8)
Microsoft Visual Studio 2022 version 17.0
Microsoft Visual Studio 2019 version 16.11 (includes 16.0 - 16.10)
.NET 5.0

Solution

Install necessary updates from the KB section, that are listed in your Windows Update (Windows Update usually can be accessed from the Control Panel)

Original advisories

CVE-2022-24526
CVE-2022-24512
CVE-2022-24464
CVE-2020-8927

Impacts
?
ACE 
[?]

DoS 
[?]

SUI 
[?]
Related products
Microsoft Visual Studio
Find out the statistics of the vulnerabilities spreading in your region