KLA12472
Multiple vulnerabilities in Mozilla Firefox ESR

Updated: 03/09/2022
Detect date
?
03/08/2022
Severity
?
High
Description

Multiple vulnerabilities were found in Mozilla Firefox ESR. Malicious users can exploit these vulnerabilities to spoof user interface, bypass security restrictions, execute arbitrary code, cause denial of service.

Below is a complete list of vulnerabilities:

  1. Security UI vulnerability in fullscreen mode can be exploited to spoof user interface,
  2. Security vulnerability in download temporary files for macOS and Linux can be exploited to bypass security restrictions.
  3. Security vulnerability in iframe sandboxed with allow-popups can be exploited to execute arbitrary code.
  4. Use after free vulnerability in text reflows can be exploited via special crafted SVG object to cause denial of service.
  5. Security vulnerability in verifying add-on signatures can be exploited to bypass security restrictions.
Affected products

Mozilla Firefox ESR earlier than 91.7.0

Solution

Update to the latest version
Download Firefox ESR

Original advisories

MFSA2022-11

Impacts
?
ACE 
[?]

DoS 
[?]

SB 
[?]

SUI 
[?]
Related products
Mozilla Firefox ESR
Find out the statistics of the vulnerabilities spreading in your region