KLA12453
Multiple vulnerabilities in Microsoft Developer Tools

Updated: 02/10/2022
Detect date
?
02/08/2022
Severity
?
High
Description

Multiple vulnerabilities were found in Microsoft Developer Tools. Malicious users can exploit these vulnerabilities to execute arbitrary code, cause denial of service.

Below is a complete list of vulnerabilities:

  1. A remote code execution vulnerability in Visual Studio Code Remote Development Extension can be exploited remotely to execute arbitrary code.
  2. A denial of service vulnerability in .NET can be exploited remotely to cause denial of service.
Affected products

Visual Studio Code
Visual Studio 2019 for Mac version 8.10
Microsoft Visual Studio 2019 version 16.11 (includes 16.0 - 16.10)
Microsoft Visual Studio 2022 version 17.0
Microsoft Visual Studio 2019 version 16.9 (includes 16.0 - 16.8)
.NET 5.0
.NET 6.0

Solution

Install necessary updates from the KB section, that are listed in your Windows Update (Windows Update usually can be accessed from the Control Panel)

Original advisories

CVE-2022-21991
CVE-2022-21986

Impacts
?
ACE 
[?]

DoS 
[?]
Related products
Microsoft .NET Framework
Microsoft Visual Studio
CVE-IDS
?
CVE-2022-219915.0Critical
CVE-2022-219865.0Critical
Find out the statistics of the vulnerabilities spreading in your region