Searching
..

Click anywhere to stop

KLA12400
Multiple vulnerabilities in Apache HTTP Server

Updated: 01/25/2024
Detect date
?
12/20/2021
Severity
?
Critical
Description

Multiple vulnerabilities were found in Apache HTTP Server. Malicious users can exploit these vulnerabilities to cause denial of service, bypass security restrictions.

Below is a complete list of vulnerabilities:

  1. NULL pointer dereference or server side request forgery (SSRF) vulnerability can be exploited remotely via special crafted URL to cause denial of service or bypass security restrictions.
  2. Buffer overflow vulnerability in mod_lua can be exploited remotely via special crafted webpage to cause denial of service.
Exploitation

Malware exists for this vulnerability. Usually such malware is classified as Exploit. More details.

Affected products

Apache HTTP Server 2.4.x earlier than 2.4.52

Solution

Update to the latest version
Download Apache HTTP Server

Original advisories

Fixed in Apache HTTP Server 2.4.52

Impacts
?
DoS 
[?]

SB 
[?]
Related products
Apache HTTP Server
CVE-IDS
?
CVE-2021-442248.2Critical
CVE-2021-447909.8Critical
Find out the statistics of the vulnerabilities spreading in your region