KLA12398
Multiple vulnerabilities in Opera

Updated: 12/27/2021
Detect date
?
12/14/2021
Severity
?
High
Description

Multiple vulnerabilities were found in Opera. Malicious users can exploit these vulnerabilities to cause denial of service, execute arbitrary code, inject malicious code, spoof user interface, bypass security restrictions.

Below is a complete list of vulnerabilities:

  1. Heap buffer overflow vulnerability in BFCache can be exploited to cause denial of service.
  2. Use after free vulnerability in web apps can be exploited to cause denial of service or execute arbitrary code.
  3. Use after free vulnerability in developer tools can be exploited to cause denial of service or execute arbitrary code.
  4. Use after free vulnerability in UI can be exploited to cause denial of service or execute arbitrary code.
  5. Use after free vulnerability in windows manager can be exploited to cause denial of service or execute arbitrary code.
  6. Type confusion vulnerability in V8 can be exploited to cause denial of service.
  7. Use after free vulnerability in file API can be exploited to cause denial of service or execute arbitrary code.
  8. Data validation vulnerability in loader can be exploited to bypass security restrictions.
  9. Use after free vulnerability in autofill can be exploited to cause denial of service or execute arbitrary code.
  10. Security UI vulnerability in autofill can be exploited to spoof user interface.
  11. Integer underflow vulnerability in ANGLE can be exploited to cause denial of service.
  12. Heap buffer overflow vulnerability in extensions can be exploited to cause denial of service.
  13. Type confusion vulnerability in loader can be exploited to cause denial of service.
  14. Validation of untrusted input vulnerability in new tab page can be exploited to bypass security restrictions.
  15. Out of bounds write vulnerability in WebRTC can be exploited to cause denial of service or execute arbitrary code.
  16. Heap buffer overflow vulnerability in ANGLE can be exploited to cause denial of service.
  17. Use after free vulnerability in screen capture can be exploited to cause denial of service or execute arbitrary code.
Affected products

Opera earlier than 82.0.4227.33

Solution

Update to the latest version
Download Opera

Original advisories

Changelog for Opera 82
Stable Channel Update for Desktop

Impacts
?
ACE 
[?]

DoS 
[?]

CI 
[?]

SB 
[?]

SUI 
[?]
Related products
Opera
CVE-IDS
?
CVE-2021-40635.0Critical
CVE-2021-40525.0Critical
CVE-2021-40555.0Critical
CVE-2021-40645.0Critical
CVE-2021-40535.0Critical
CVE-2021-40595.0Critical
CVE-2021-40575.0Critical
CVE-2021-40615.0Critical
CVE-2021-40685.0Critical
CVE-2021-40665.0Critical
CVE-2021-40585.0Critical
CVE-2021-40545.0Critical
CVE-2021-40675.0Critical
CVE-2021-40625.0Critical
CVE-2021-40565.0Critical
CVE-2021-40655.0Critical
CVE-2021-40795.0Critical
CVE-2021-40785.0Critical
Find out the statistics of the vulnerabilities spreading in your region