KLA12373
Multiple vulnerabilities in Google Chrome

Updated: 12/16/2021
Detect date
?
12/06/2021
Severity
?
High
Description

Multiple vulnerabilities were found in Google Chrome. Malicious users can exploit these vulnerabilities to execute arbitrary code, cause denial of service, inject malicious code, bypass security restrictions, spoof user interface.

Below is a complete list of vulnerabilities:

  1. Use after free vulnerability in developer tools can be exploited to cause denial of service or execute arbitrary code.
  2. Use after free vulnerability in web apps can be exploited to cause denial of service or execute arbitrary code.
  3. Heap buffer overflow vulnerability in extensions can be exploited to cause denial of service.
  4. Use after free vulnerability in screen capture can be exploited to cause denial of service or execute arbitrary code.
  5. Use after free vulnerability in UI can be exploited to cause denial of service or execute arbitrary code.
  6. Data validation vulnerability in loader can be exploited to bypass security restrictions.
  7. Use after free vulnerability in file API can be exploited to cause denial of service or execute arbitrary code.
  8. Type confusion vulnerability in V8 can be exploited to cause denial of service.
  9. Validation of untrusted input vulnerability in new tab page can be exploited to bypass security restrictions.
  10. Integer underflow vulnerability in ANGLE can be exploited to cause denial of service.
  11. Heap buffer overflow vulnerability in ANGLE can be exploited to cause denial of service.
  12. Security UI vulnerability in autofill can be exploited to spoof user interface.
  13. Use after free vulnerability in windows manager can be exploited to cause denial of service or execute arbitrary code.
  14. Heap buffer overflow vulnerability in BFCache can be exploited to cause denial of service.
  15. Type confusion vulnerability in loader can be exploited to cause denial of service.
  16. Use after free vulnerability in autofill can be exploited to cause denial of service or execute arbitrary code.
  17. Out of bounds write vulnerability in WebRTC can be exploited to cause denial of service or execute arbitrary code.
Affected products

Google Chrome earlier than 96.0.4664.93

Solution

Update to the latest version
Download Google Chrome

Original advisories

Stable Channel Update for Desktop

Impacts
?
ACE 
[?]

DoS 
[?]

CI 
[?]

SB 
[?]

SUI 
[?]
Related products
Google Chrome
Find out the statistics of the vulnerabilities spreading in your region