KLA12370
Multiple vulnerabilities in Apache HTTP Server

Updated: 12/02/2021
Detect date
?
09/16/2021
Severity
?
High
Description

Multiple vulnerabilities were found in Apache HTTP Server. Malicious users can exploit these vulnerabilities to bypass security restrictions, obtain sensitive information, spoof user interface, cause denial of service.

Below is a complete list of vulnerabilities:

  1. Security bypass vulnerability in mod_proxy can be exploited via special crafted HTTP/2 method to bypass security restrictions.
  2. Buffer overflow vulnerability in ap_escape_quotes can be exploited to spoof user interface or obtain sensitive information.
  3. NULL pointer dereference in httpd core can be exploited to cause denial of service.
  4. Out of bounds read vulnerability in mod_proxy_uwsgi can be exploited vis special crafted request to cause denial of service.
  5. Security bypass vulnerability in mod_proxy can be exploited remotely via special crafted request to cause denial of service.
Affected products

Apache HTTP Server earlier than 2.4.49

Solution

Update to the latest version
Download Apache HTTP Server

Original advisories

Fixed in Apache HTTP Server 2.4.49

Impacts
?
OSI 
[?]

DoS 
[?]

SB 
[?]

SUI 
[?]
Related products
Apache HTTP Server
CVE-IDS
?
CVE-2021-331935.0Critical
CVE-2021-392757.5Critical
CVE-2021-347985.0Critical
CVE-2021-361605.0Critical
CVE-2021-404386.8High
Find out the statistics of the vulnerabilities spreading in your region