KLA12369
Multiple vulnerabilities in Apache HTTP Server

Updated: 12/02/2021
Detect date
?
06/01/2021
Severity
?
High
Description

Multiple vulnerabilities were found in Apache HTTP Server. Malicious users can exploit these vulnerabilities to cause denial of service, bypass security restrictions.

Below is a complete list of vulnerabilities:

  1. Heap overflow vulnerability in mod_session can be exploited via special crafted SessionHandler to cause denial of service.
  2. NULL pointer dereference vulnerability in mod_session can be exploited via special crafted coockie header to cause denial of service.
  3. Security bypass vulnerability vulnerability in httpd can be exploited to bypass security restrictions.
  4. NULL pointer dereference vulnerability in mod_http2 can be exploited via special crafted HTTP/2 request to cause denial of service.
  5. Security bypass vulnerability in mod_proxy_wstunnel can be exploited to bypass security restrictions.
  6. Stack overflow vulnerability in mod_auth_digest can be exploited bia specia crafted digest to cause denial of service.
  7. Security bypass vulnerability in “MergeSlashes OFF” can be exploited via special crafted URL to bypass security restrictions.
  8. NULL pointer dereference vulnerability in mod_proxy_http can be exploited via special crafted requests to cause denial of service.
Affected products

Apache HTTP Server earlier than 2.4.48

Solution

Update to the latest version
Download Apache HTTP Server

Original advisories

Fixed in Apache HTTP Server 2.4.48

Impacts
?
DoS 
[?]

SB 
[?]
Related products
Apache HTTP Server
CVE-IDS
?
CVE-2021-266917.5Critical
CVE-2021-266905.0Critical
CVE-2020-139382.1Warning
CVE-2021-316185.0Critical
CVE-2019-175675.0Critical
CVE-2020-354526.8High
CVE-2021-306415.0Critical
CVE-2020-139505.0Critical
Find out the statistics of the vulnerabilities spreading in your region