KLA12368
Multiple vulnerabilities in Apache HTTP Server

Updated: 12/02/2021
Detect date
?
08/07/2020
Severity
?
High
Description

Multiple vulnerabilities were found in Apache HTTP Server. Malicious users can exploit these vulnerabilities to cause denial of service, execute arbitrary code, obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. Denial of service vulnerability in “Cache-Digest” header can be exploited via special crafted HTTP/2 request to cause denial of service.
  2. Denial of service vulnerability in mod_http2 can be exploited to cause denial of service.
  3. Buffer overflow vulnerability mod_proxy_uwsgi can be exploited remotely to obtain sensitive information or execute arbitrary code.
Affected products

Apache HTTP Server earlier than 2.4.44

Solution

Update to the latest version
Download Apache HTTP Server

Original advisories

Fixed in Apache HTTP Server 2.4.44

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]
Related products
Apache HTTP Server
CVE-IDS
?
CVE-2020-94905.0Critical
CVE-2020-119934.3Warning
CVE-2020-119847.5Critical
Find out the statistics of the vulnerabilities spreading in your region