KLA12365
Multiple vulnerabilities in Apache HTTP Server

Updated: 01/18/2022
Detect date
?
04/01/2019
Severity
?
High
Description

Multiple vulnerabilities were found in Apache HTTP Server. Malicious users can exploit these vulnerabilities to cause denial of service, bypass security restrictions, obtain sensitive information, execute arbitrary code.

Below is a complete list of vulnerabilities:

  1. Denial of service vulnerability in mod_http2 can be exploited via special crafted request to cause denial of service.
  2. Security bypass vulnerability in mod_ssl can be exploited to bypass security restrictions.
  3. Information disclosure vulnerability in URL normalization can be exploited to obtain sensitive information.
  4. Code execution vulnerability in less-privileged child processes or threads can be exploited to execute arbitrary code.
  5. Use after free vulnerability in mod_http2 can be exploited to cause denial of service.
  6. Security bypass vulnerability in mod_auth_digest can be exploited to bypass security restrictions.
Exploitation

The following public exploits exists for this vulnerability:

https://www.exploit-db.com/exploits/46676

Affected products

Apache HTTP Server earlier than 2.4.39

Solution

Update to the latest version
Download Apache HTTP Server

Original advisories

Fixed in Apache HTTP Server 2.4.39

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]
Related products
Apache HTTP Server
CVE-IDS
?
CVE-2019-01974.9Warning
CVE-2019-02156.0High
CVE-2019-02205.0Critical
CVE-2019-02117.2High
CVE-2019-01965.0Critical
CVE-2019-02176.0High
Find out the statistics of the vulnerabilities spreading in your region