KLA12361
Multiple vulnerabilities in Apache HTTP Server

Updated: 12/02/2021
Detect date
?
03/21/2018
Severity
?
Warning
Description

Multiple vulnerabilities were found in Apache HTTP Server. Malicious users can exploit these vulnerabilities to cause denial of service, bypass security restrictions, obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. Out of bounds read vulnerability in mod_cache_socache can be exploited to cause denial of service.
  2. Security bypass vulnerability in mod_auth_digest can be exploited to bypass security restrictions.
  3. Use after free vulnerability on HTTP/2 stream shutdown can be exploited to cause denial of service.
  4. Out of bound access vulnerability in HTTP request can be exploited via special crafted request to cause denial of service.
  5. Out of bounds write vulnerability in mod_authnz_ldap can be exploited to cause denial of service.
  6. Security bypass vulnerability in filename can be exploited to bypass security restrictions.
  7. Information disclosure vulnerability in “Session” header can be exploited remotely to obtain sensitive information.
Affected products

Apache HTTP Server earlier than 2.4.33

Solution

Update to the latest version
Download Apache HTTP Server

Original advisories

Fixed in Apache HTTP Server 2.4.33

Impacts
?
OSI 
[?]

DoS 
[?]

SB 
[?]
Related products
Apache HTTP Server
CVE-IDS
?
CVE-2018-13035.0Critical
CVE-2018-13126.8High
CVE-2018-13024.3Warning
CVE-2018-13014.3Warning
CVE-2017-157105.0Critical
CVE-2017-157156.8High
CVE-2018-12833.5Warning
Find out the statistics of the vulnerabilities spreading in your region