Kaspersky ID:
KLA12351
Detect Date:
11/19/2021
Updated:
01/25/2024

Description

Multiple vulnerabilities were found in Microsoft Browser. Malicious users can exploit these vulnerabilities to execute arbitrary code, cause denial of service, bypass security restrictions, spoof user interface, obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. Use after free vulnerability in storage foundation can be exploited to cause denial of service or execute arbitrary code.
  2. Policy enforcement vulnerability in CORS can be exploited to bypass security restrictions.
  3. Implementation vulnerability in cache can be exploited to cause denial of service.
  4. Implementation vulnerability in service can be exploited to cause denial of service.
  5. Implementation vulnerability in input can be exploited to cause denial of service.
  6. Type confusion vulnerability in V8 can be exploited to cause denial of service.
  7. Spoofing vulnerability in Microsoft Edge can be exploited to spoof user interface.
  8. Spoofing vulnerability in Microsoft Edge for iOS can be exploited to spoof user interface.
  9. Remote code execution vulnerability in Microsoft Edge can be exploited remotely to execute arbitrary code.
  10. Implementation vulnerability in WebAuthentication can be exploited to cause denial of service.
  11. Heap buffer overflow vulnerability in fingerprint recognition can be exploited to cause denial of service.
  12. Implementation vulnerability in navigation can be exploited to cause denial of service.
  13. Policy enforcement vulnerability in sandbox can be exploited to bypass security restrictions.
  14. Policy enforcement vulnerability in contacts picker can be exploited to bypass security restrictions.
  15. Implementation vulnerability in referrer can be exploited to cause denial of service.
  16. Use after free vulnerability in media can be exploited to cause denial of service or execute arbitrary code.
  17. Use after free vulnerability in loader can be exploited to cause denial of service or execute arbitrary code.
  18. Policy enforcement vulnerability in background fetch can be exploited to bypass security restrictions.
  19. Out of bounds write vulnerability in Swiftshader can be exploited to cause denial of service or execute arbitrary code.

Original advisories

Related products

CVE list

  • CVE-2021-38011
    critical
  • CVE-2021-38010
    high
  • CVE-2021-38012
    critical
  • CVE-2021-38019
    high
  • CVE-2021-38006
    critical
  • CVE-2021-38008
    critical
  • CVE-2021-38021
    high
  • CVE-2021-38005
    critical
  • CVE-2021-38015
    critical
  • CVE-2021-38017
    critical
  • CVE-2021-38013
    critical
  • CVE-2021-38020
    warning
  • CVE-2021-38016
    critical
  • CVE-2021-38014
    critical
  • CVE-2021-38007
    critical
  • CVE-2021-38009
    high
  • CVE-2021-38018
    high
  • CVE-2021-38022
    high
  • CVE-2021-42308
    warning
  • CVE-2021-43220
    warning
  • CVE-2021-43221
    warning

KB list

Read more

Find out the statistics of the vulnerabilities spreading in your region on statistics.securelist.com

Found an inaccuracy in the description of this vulnerability? Let us know!
Kaspersky IT Security Calculator
Calculate
Check now
Learn more about cybersecurity on Kaspersky Encyclopedia
For free
Learn more
Confirm changes?
Your message has been sent successfully.