KLA12269
Multiple vulnerabilities in Opera

Updated: 09/03/2021
Detect date
?
08/11/2021
Severity
?
High
Description

Multiple vulnerabilities were found in Opera. Malicious users can exploit these vulnerabilities to execute arbitrary code, cause denial of service, obtain sensitive information, spoof user interface.

Below is a complete list of vulnerabilities:

  1. Use after free vulnerability in Page Info UI can be exploited to cause denial of service or execute arbitrary code.
  2. Heap buffer overflow vulnerability in Bookmarks can be exploited to cause denial of service or execute arbitrary code.
  3. Use after free vulnerability in Browser UI can be exploited to cause denial of service or execute arbitrary code.
  4. Out of bounds read vulnerability in Tab Strip can be exploited to cause denial of service or obtain sensitive information.
  5. Use after free vulnerability in File System API can be exploited to cause denial of service or execute arbitrary code.
  6. Incorrect security UI vulnerability in Navigation can be exploited to obtain sensitive information and spoof user interface.
  7. Out of bounds write vulnerability in Tab Groups can be exploited to cause denial of service or execute arbitrary code.
Affected products

Opera earlier than 78.0.4093.147

Solution

Update to the latest version
Download Opera

Original advisories

Changelog for Opera 78
Stable Channel Update for Desktop

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SUI 
[?]
Related products
Opera
CVE-IDS
?
CVE-2021-305910.0Unknown
CVE-2021-305900.0Unknown
CVE-2021-305970.0Unknown
CVE-2021-305920.0Unknown
CVE-2021-305940.0Unknown
CVE-2021-305930.0Unknown
CVE-2021-305960.0Unknown
Find out the statistics of the vulnerabilities spreading in your region