KLA12144
Multiple vulnerabiltiies in Google Chrome

Updated: 04/22/2021
Detect date
?
04/14/2021
Severity
?
High
Description

Multiple vulnerabilities were found in Google Chrome. Malicious users can exploit these vulnerabilities to cause denial of service, bypass security restrictions, execute arbitrary code, obtain sensitive information, spoof user interface.

Below is a complete list of vulnerabilities:

  1. An implementation vulnerability in Autofill can be exploited to cause denial of service.
  2. A validation of untrusted input vulnerability in Mojo can be exploited to bypass security restrictions.
  3. A use after free vulnerability in permissions can be exploited to cause denial of service or execute arbitrary code.
  4. A use after free vulnerability in extentions can be exploited to cause denial of service or execute arbitrary code.
  5. An implementation vulnerability in storage component can be exploited to cause denial of service.
  6. A policy enforcement vulnerability in navigation component to bypass security restrictions.
  7. A use after free vulnerability in WebMIDI can be exploited to cause denial of service or execute arbitrary code.
  8. A use after free vulnerability in Blink can be exploited to cause denial of service or execute arbitrary code.
  9. An implementation vulnerability in Network can be exploited to cause denial of service.
  10. An uninitialized use vulnerability in PDFium can be exploited to obtain sensitive information.
  11. A security UI vulnerability in Network Config UI can be exploited to spoof user interface.
  12. An implementation vulnerability in Navigation can be exploited to cause denial of service.
  13. A use after free vulnerability in IndexedDB can be exploited to cause denial of service or execute arbitrary code.
  14. A use after free vulnerability in Network API can be exploited to cause denial of service or execute arbitrary code.
  15. A data validation vulnerability in QR scanner can be exploited to bypass security restrictions.
Affected products

Google Chrome earlier than 90.0.4430.72

Solution

Update to the latest version
Download Google Chrome

Original advisories

Stable Channel Update for Desktop

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]

SUI 
[?]
Related products
Google Chrome
CVE-IDS
?
Find out the statistics of the vulnerabilities spreading in your region