KLA12129
Multiple vulnerabilities in Mozilla Thunderbird

Updated: 03/24/2021
Detect date
?
03/23/2021
Severity
?
High
Description

Multiple vulnerabilities were found in Mozilla Thunderbird. Malicious users can exploit these vulnerabilities to obtain sensitive information, spoof user interface, execute arbitrary code, cause denial of service.

Below is a complete list of vulnerabilities:

  1. A security UI vulnerability can be exploited via special crafted extention to spoof user interface and obtain sensitive information.
  2. A memory safety vulnerability can be exploited to execute arbitrary code.
  3. An out of bounds read vulnerability in WebGL can be exploited via special crafted object to cause denial of service or obtain sensitive information.
  4. An information disclosure vulnerability can be exploited via special crafted webpage to obtain sensitive information.
Affected products

Mozilla Thunderbird earlier than 78.9

Solution

Update to the latest version
Download Thunderbird

Original advisories

MFSA2021-12

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SUI 
[?]
Related products
Mozilla Thunderbird
CVE-IDS
?
CVE-2021-239870.0Unknown
CVE-2021-239820.0Unknown
CVE-2021-239840.0Unknown
CVE-2021-239810.0Unknown
Find out the statistics of the vulnerabilities spreading in your region